cornucopia: bump SRCREV
[openembedded.git] / recipes / clutter / clutter_1.2.12.bb
blobfd6247fc5f6adc332e94fc47c3f68f9daefe9fb9
1 require clutter.inc
3 PR = "${INC_PR}.1"
5 SRC_URI = "http://source.clutter-project.org/sources/clutter/1.2/clutter-${PV}.tar.bz2 \
6 file://workaround-broken-mipmaps.patch \
7 ${INC_SRC_URI} \
10 # recommended for --clutter-debug / --cogl-debug params
11 BASE_CONF += " --enable-debug"
13 do_configure_prepend() {
14 # align the test data location *.c (V1.2 uses macro ASSETS_DIR for path in *.c)
15 for i in $(find ${S}/tests -name Makefile.am) ; do
16 sed -i -e 's:$(top_srcdir)/tests/data:${datadir}/${PN}-tests:g' $i
17 done
20 do_compile_prepend() {
21 rebuild_shader_sources ${S}/clutter/cogl/cogl/driver/gles
22 # align test data location *.json
23 for full_name in $(find ${S}/tests/data -name *.png -o -name *.json) ; do
24 data_name=${full_name##*/}
25 for i in $(find ${S}/tests -name *.json) ; do
26 sed -i -e s:${data_name}:${datadir}/${PN}-tests/${data_name}:g $i
27 done
28 done
31 do_install() {
32 autotools_do_install
33 install_tests
36 SRC_URI[md5sum] = "76f70e765adcf7146be1ceb50bafa14f"
37 SRC_URI[sha256sum] = "4582e6579897374d1f8ce51daa330311ebb90033fad95d5f076c1e9392b4ae68"