cornucopia: bump SRCREV
[openembedded.git] / recipes / gnome / gnome-games_2.32.0.bb
blob9c103afea5b384929bd33bd542440202df5b4a2e
1 LICENSE = "GPL"
2 DEPENDS = "guile libggz ggz-client-libs python-pygtk gtk+ libgnome libgnomeui librsvg gnome-vfs gconf libglade gnome-common gnome-python-desktop gnome-python gstreamer"
4 inherit gnome distutils-base gconf
6 SRC_URI[archive.md5sum] = "b42878d253fb9aa579cb19d9a960c750"
7 SRC_URI[archive.sha256sum] = "7cd2a282071b1b9cdff8a7102abddc26e253af7b3094551220addf2b3a2850c2"
9 EXTRA_OECONF += " \
10 --enable-omitgames=quadrapassel,lightsoff,swell-foop,gnibbles \
11 --with-libggz-includes=${STAGING_INCDIR} \
12 --with-libggz-libraries=${STAGING_LIBDIR} \
13 --with-ggzmod-includes=${STAGING_INCDIR} \
14 --with-ggzmod-libraries=${STAGING_LIBDIR} \
15 --with-ggzcore-includes=${STAGING_INCDIR} \
16 --with-ggzcore-libraries=${STAGING_LIBDIR} \
17 --disable-tests \
18 --disable-scrollkeeper \
19 am__fastdepCXX_TRUE='#' \
20 INTLTOOL_PERL=${STAGING_BINDIR_NATIVE}/perl \
23 do_configure_append() {
24 for i in $(find ${S} -name "Makefile") ; do
25 sed -i -e s:'I/usr/include'::g -e s:'-I /usr/include -I /usr/local/include'::g $i
26 done
29 # copy matchbox icons
30 do_install_append() {
31 install -d ${D}/${datadir}/pixmaps
32 install -m 0644 ${D}/${datadir}/icons/hicolor/48x48/apps/* ${D}/${datadir}/pixmaps
35 CFLAGS_append = " -lguile -lgmp -lcrypt -lm -lltdl"
37 FILES_${PN}-doc += " ${datadir}/gnome/help"
38 FILES_${PN}-dbg += " ${bindir}/.debug ${libdir}/gnome-games/.debug"
40 ALLOW_EMPTY_${PN} = "1"
41 RDEPENDS_${PN} += "gnome-games-aisleriot gnome-games-cards gnome-games-glchess gnome-games-glines gnome-games-gnect gnome-games-gnobots2 gnome-games-gnomine gnome-games-gnotravex gnome-games-gnotski gnome-games-gtali gnome-games-iagno gnome-games-mahjongg gnome-games-sudoku "
43 PACKAGES =+ "gnome-games-common"
44 DESCRIPTION_gnome-games-common = "GNOME games common resources"
45 FILES_gnome-games-common = "${datadir}/ggz \
46 ${libdir}/ggz \
47 ${sysconfdir} \
48 ${datadir}/gnome-games/icons \
49 ${datadir}/icons \
50 ${datadir}/gnome-games/sounds"
51 # svg is needed for --enable-scalable by nearly all, so put into -common
52 RDEPENDS_gnome-games-common = "librsvg librsvg-gtk"
54 PACKAGES =+ "gnome-games-cards"
55 DESCRIPTION_gnome-games-cards = "GNOME games playing card resources"
56 FILES_gnome-games-cards = "${datadir}/gnome-games/pixmaps \
57 ${libdir}/gnome-games/gnome-games-render-cards \
58 ${datadir}/gnome-games-common/cards"
60 PACKAGES =+ "gnome-games-gnomine"
61 DESCRIPTION_gnome-games-gnomine = "GNOME minesweeper game"
62 RDEPENDS_gnome-games-gnomine = "gnome-games-common"
63 FILES_gnome-games-gnomine = "${bindir}/gnomine \
64 ${datadir}/gnome-games/gnomine \
65 ${datadir}/pixmaps/gnome-mines.png \
66 ${datadir}/applications/gnomine.desktop \
67 ${sysconfdir}/gconf/schemas/gnomine.schemas \
68 /var/games/gnomine.*.scores"
70 PACKAGES =+ "gnome-games-aisleriot"
71 DESCRIPTION_gnome-games-aisleriot = "GNOME solitaire games"
72 RDEPENDS_gnome-games-aisleriot = "gnome-games-common gnome-games-cards"
73 FILES_gnome-games-aisleriot = "${bindir}/sol \
74 ${datadir}/gnome-games/aisleriot \
75 ${datadir}/pixmaps/gnome-aisleriot.png \
76 ${datadir}/pixmaps/gnome-freecell.png \
77 ${datadir}/applications/sol.desktop \
78 ${datadir}/applications/freecell.desktop \
79 ${sysconfdir}/gconf/schemas/aisleriot.schemas"
81 PACKAGES =+ "gnome-games-gnect"
82 DESCRIPTION_gnome-games-gnect = "GNOME four-in-a-row game"
83 RDEPENDS_gnome-games-gnect = "gnome-games-common"
84 FILES_gnome-games-gnect = "${bindir}/gnect \
85 ${datadir}/gnect \
86 ${datadir}/gnome-games/gnect \
87 ${datadir}/pixmaps/gnome-gnect.png \
88 ${datadir}/applications/gnect.desktop \
89 ${sysconfdir}/gconf/schemas/gnect.schemas"
91 PACKAGES =+ "gnome-games-mahjongg"
92 DESCRIPTION_gnome-games-mahjongg = "GNOME mahjongg game"
93 RDEPENDS_gnome-games-mahjongg = "gnome-games-common"
94 FILES_gnome-games-mahjongg = "${bindir}/mahjongg \
95 ${datadir}/gnome-games/mahjongg \
96 ${datadir}/pixmaps/gnome-mahjongg.png \
97 ${datadir}/applications/mahjongg.desktop \
98 ${sysconfdir}/gconf/schemas/mahjongg.schemas \
99 /var/games/mahjongg.*.scores"
101 PACKAGES =+ "gnome-games-gtali"
102 DESCRIPTION_gnome-games-gtali = "GNOME yahtzee game"
103 RDEPENDS_gnome-games-gtali = "gnome-games-common"
104 FILES_gnome-games-gtali = "${bindir}/gtali \
105 ${datadir}/gnome-games/gtali \
106 ${datadir}/pixmaps/gnome-tali.png \
107 ${datadir}/applications/gtali.desktop \
108 ${sysconfdir}/gconf/schemas/gtali.schemas \
109 /var/games/gtali.*.scores"
111 PACKAGES =+ "gnome-games-gnotravex"
112 DESCRIPTION_gnome-games-gnotravex = "GNOME tile matching game"
113 RDEPENDS_gnome-games-gnotravex = "gnome-games-common"
114 FILES_gnome-games-gnotravex = "${bindir}/gnotravex \
115 ${datadir}/gnome-games/gnotravex \
116 ${datadir}/pixmaps/gnome-tetravex.png \
117 ${datadir}/applications/gnotravex.desktop \
118 ${sysconfdir}/gconf/schemas/gnotravex.schemas \
119 /var/games/gnotravex.*.scores"
121 PACKAGES =+ "gnome-games-gnotski"
122 DESCRIPTION_gnome-games-gnotski = "GNOME blocks puzzle game"
123 RDEPENDS_gnome-games-gnotski = "gnome-games-common"
124 FILES_gnome-games-gnotski = "${bindir}/gnotski \
125 ${datadir}/gnome-games/gnotski \
126 ${datadir}/pixmaps/gnome-klotski.png \
127 ${datadir}/applications/gnotski.desktop \
128 ${sysconfdir}/gconf/schemas/gnotski.schemas \
129 /var/games/gnotski.*.scores"
131 PACKAGES =+ "gnome-games-glines"
132 DESCRIPTION_gnome-games-glines = "GNOME five-or-more game"
133 RDEPENDS_gnome-games-glines = "gnome-games-common"
134 FILES_gnome-games-glines = "${bindir}/glines \
135 ${datadir}/gnome-games/glines \
136 ${datadir}/pixmaps/gnome-glines.png \
137 ${datadir}/applications/glines.desktop \
138 ${sysconfdir}/gconf/schemas/glines.schemas \
139 /var/games/glines.*.scores"
141 PACKAGES =+ "gnome-games-iagno"
142 DESCRIPTION_gnome-games-iagno = "GNOME reversi game"
143 RDEPENDS_gnome-games-iagno = "gnome-games-common"
144 FILES_gnome-games-iagno = "${bindir}/iagno \
145 ${datadir}/gnome-games/iagno \
146 ${datadir}/pixmaps/gnome-iagno.png \
147 ${datadir}/applications/iagno.desktop \
148 ${sysconfdir}/gconf/schemas/iagno.schemas"
150 PACKAGES =+ "gnome-games-gnobots2"
151 DESCRIPTION_gnome-games-gnobots2 = "GNOME robots game"
152 RDEPENDS_gnome-games-gnobots2 = "gnome-games-common"
153 FILES_gnome-games-gnobots2 = "${bindir}/gnobots2 \
154 ${datadir}/gnome-games/gnobots2 \
155 ${datadir}/pixmaps/gnome-robots.png \
156 ${datadir}/applications/gnobots2.desktop \
157 ${sysconfdir}/gconf/schemas/gnobots2.schemas \
158 /var/games/gnobots2.*.scores"
160 PACKAGES =+ "gnome-games-glchess"
161 DESCRIPTION_gnome-games-glchess = "GNOME chess"
162 RDEPENDS_gnome-games-glchess = "python-pygtk python-codecs \
163 python-netclient python-xml \
164 gnome-python"
165 FILES_gnome-games-glchess = "${bindir}/glchess \
166 ${bindir}/gnome-gnuchess \
167 ${datadir}/glchess \
168 ${datadir}/pixmaps/gnome-glchess.png \
169 ${datadir}/applications/glchess.desktop \
170 ${sysconfdir}/gconf/schemas/glchess.schemas \
171 ${libdir}/python2.5/site-packages/glchess"
173 PACKAGES =+ "gnome-games-sudoku"
174 DESCRIPTION_gnome-games-sudoku = "GNOME sudoku"
175 RDEPENDS_gnome-games-sudoku = "python-pygtk python-codecs python-difflib \
176 python-xml python-netclient \
177 python-textutils python-threading \
178 gnome-python gnome-python-desktop"
179 FILES_gnome-games-sudoku = "${bindir}/gnome-sudoku \
180 ${datadir}/gnome-sudoku \
181 ${datadir}/pixmaps/gnome-sudoku.png \
182 ${datadir}/applications/gnome-sudoku.desktop \
183 ${libdir}/python2.5/site-packages/gnome_sudoku"