1 DESCRIPTION
= "GST output sink for Omapfb"
6 DEPENDS
= "gstreamer virtual/libx11 virtual/kernel"
8 SRCREV
= "6f0b1cb50d1c67c3a3db2f11246256060ac871de"
9 PV
= "0.0+${PR}+gitr${SRCREV}"
11 SRC_URI
= "git://github.com/felipec/${PN}.git;protocol=git \
12 file://0001-Implement-XOverlay-and-I420-to-422-colorspace-conver.patch"
16 # We want a kernel header
for armv7a
, but we don't want
to make gst
-omapfb machine specific
for that
17 STAGING_KERNEL_DIR
= "${STAGING_DIR}/${MACHINE_ARCH}${TARGET_VENDOR}-${TARGET_OS}/kernel"
19 EXTRA_OEMAKE
= " KERNEL=${STAGING_KERNEL_DIR}"
22 TARGET_CC_ARCH
+= "${CFLAGS} ${LDFLAGS}"
24 do_configure_prepend
() {
26 cp $
{STAGING_KERNEL_DIR
}/arch
/arm
/plat
-omap
/include/mach
/omapfb.h $
{S
}/linux ||
true
27 cp $
{STAGING_KERNEL_DIR
}/include/asm
-arm
/arch
-omap
/omapfb.h $
{S
}/linux ||
true
28 cp $
{STAGING_KERNEL_DIR
}/include/linux
/omapfb.h $
{S
}/linux ||
true
29 sed
-e 's
/__user
//g'
-i $
{S
}/linux
/omapfb.h
33 install
-d $
{D
}$
{libdir
}/gstreamer
-0.10
34 install
-m
0755 libgstomapfb.so $
{D
}$
{libdir
}/gstreamer
-0.10
37 FILES_$
{PN
} += "${libdir}/gstreamer-0.10/libgstomapfb.so"
38 FILES_$
{PN
}-dbg
+= "${libdir}/gstreamer-0.10/.debug"