1 # initramfs image with interactive boot menu allowing
to select rootfs location
2 # from choices of block devices
, loopback images
and NFS.
4 IMAGE_INSTALL
= "busybox-static initramfs-module-bootmenu initramfs-module-check-modules initramfs-module-kexecboot klibc-static-utils-modprobe"
8 # Remove any kernel
-image that the kernel
-module
-* packages may have pulled in.
9 PACKAGE_REMOVE
= "kernel-image-* update-modules module-init-tools-depmod update-rc.d uclibc"
10 ROOTFS_POSTPROCESS_COMMAND
+= "opkg-cl ${IPKG_ARGS} -force-depends \
11 remove ${PACKAGE_REMOVE};"
13 IMAGE_FSTYPES
+= " cpio.gz "