cornucopia: bump SRCREV
[openembedded.git] / recipes / inetutils / inetutils_1.5.bb
blobdba140f3a803e673948085c5a1cefe4ea771304d
1 SECTION = "libs"
2 DEPENDS = "ncurses fakeroot-native"
3 LICENSE = "GPL"
4 DESCRIPTION = "The GNU inetutils are a collection of common \
5 networking utilities and servers including ftp, ftpd, rcp, \
6 rexec, rlogin, rlogind, rsh, rshd, syslog, syslogd, talk, \
7 talkd, telnet, telnetd, tftp, tftpd, and uucpd."
9 PR = "r7"
11 SRC_URI = "${GNU_MIRROR}/inetutils/inetutils-${PV}.tar.gz \
14 inherit autotools
16 EXTRA_OECONF = "--with-ncurses-include-dir=${STAGING_INCDIR}"
18 do_configure_prepend () {
19 cp ${STAGING_DATADIR_NATIVE}/gettext/config.rpath ${S}/build-aux/config.rpath
20 rm -f ${S}/glob/configure*
23 fakeroot do_install () {
24 autotools_do_install
25 install -d ${D}${base_sbindir} ${D}${base_bindir}
26 mv ${D}${bindir}/tftp ${D}${bindir}/tftp.${PN}
27 mv ${D}${bindir}/telnet ${D}${bindir}/telnet.${PN}
28 mv ${D}${bindir}/logger ${D}${bindir}/logger.${PN}
29 mv ${D}${bindir}/traceroute ${D}${bindir}/traceroute.${PN}
30 mv ${D}${bindir}/hostname ${D}${base_bindir}/hostname.${PN}
31 mv ${D}${bindir}/ifconfig ${D}${base_sbindir}/ifconfig.${PN}
34 pkg_postinst_${PN} () {
35 update-alternatives --install ${bindir}/tftp tftp tftp.${PN} 100
36 update-alternatives --install ${bindir}/telnet telnet telnet.${PN} 100
37 update-alternatives --install ${bindir}/logger logger logger.${PN} 100
38 update-alternatives --install ${bindir}/traceroute traceroute traceroute.${PN} 100
39 update-alternatives --install ${base_bindir}/hostname hostname hostname.${PN} 100
40 update-alternatives --install ${base_sbindir}/ifconfig ifconfig ifconfig.${PN} 100
43 pkg_prerm_${PN} () {
44 update-alternatives --remove tftp tftp.${PN}
45 update-alternatives --remove telnet telnet.${PN}
46 update-alternatives --remove logger logger.${PN}
47 update-alternatives --remove traceroute traceroute.${PN}
48 update-alternatives --remove ifconfig ifconfig.${PN}
51 SRC_URI[md5sum] = "aeacd11d19bf25c89d4eff38346bdfb9"
52 SRC_URI[sha256sum] = "345c73b4afd7a4ff8d23af820ccc4d01c4c3ccc01ea9c964c85cdafe5cf11511"