cornucopia: bump SRCREV
[openembedded.git] / recipes / irda-utils / irda-utils_0.9.16.bb
blobbb11cda34ba625637b002ae7377512938a83f8cc
1 DESCRIPTION = "Provides common files needed to use IrDA. \
2 IrDA allows communication over Infrared with other devices \
3 such as phones and laptops."
4 SECTION = "base"
5 LICENSE = "GPL"
6 PR = "r9"
8 SRC_URI = "${SOURCEFORGE_MIRROR}/irda/irda-utils-${PV}.tar.gz \
9 file://configure.patch \
10 file://m4.patch \
11 file://ldflags.patch \
12 file://sbindir.patch \
13 file://init"
15 export SYS_INCLUDES="-I${STAGING_INCDIR}"
17 inherit autotools
19 INITSCRIPT_NAME = "irattach"
20 INITSCRIPT_PARAMS = "defaults 20"
22 do_compile () {
23 oe_runmake -e -C irattach
24 oe_runmake -e -C irdaping
27 do_install () {
28 install -d ${D}${sbindir}
29 oe_runmake -C irattach ROOT="${D}" sbindir="${sbindir}" install
30 oe_runmake -C irdaping ROOT="${D}" sbindir="${sbindir}" install
32 install -d ${D}${sysconfdir}/init.d
33 install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
36 SRC_URI[md5sum] = "2ff18f0571b5a331be7cd22fc3decd41"
37 SRC_URI[sha256sum] = "09a30fa12d81014b2877e8b5c36f5a341788579669d72f2dec0e29d22efe11e9"