cornucopia: bump SRCREV
[openembedded.git] / recipes / juce / juce_1.29.bb
blob58617246c4d57149c9f406bdc84120af2f62a531
1 DESCRIPTION = "JUCE is a cross-platform application framework"
2 HOMEPAGE = "http://www.rawmaterialsoftware.com/juce"
3 AUTHOR = "Julian Stoerer"
4 LICENSE = "GPL"
5 DEPENDS = "alsa-lib freetype virtual/libx11"
6 do_unpack[depends] += "unzip-native:do_populate_sysroot"
7 PR = "r0"
9 #FIXME the patches are a) HACKS and b) something's wrong with lineend conversion
10 SRC_URI = "http://downloads.openmoko.org/sources/juce_${@bb.data.getVar('PV',d,1).split('.')[0]}_${@bb.data.getVar('PV',d,1).split('.')[1]}.zip \
11 file://remove-x86isms.patch \
12 file://no-opengl.patch"
13 S = "${WORKDIR}/juce"
15 LIB = "libjuce_debug"
17 do_compile() {
18 cd ${S}/build/linux && oe_runmake
19 cd ${S}/demo/build/linux && oe_runmake
22 do_stage() {
23 oe_libinstall -a -C bin ${LIB} ${STAGING_LIBDIR}
24 #FIXME add includes
27 do_install() {
28 install -d ${D}${bindir}
29 install -m 0655 demo/build/linux/build/jucedemo ${D}${bindir}
32 PACKAGES = "${PN}-dbg jucedemo ${PN}"
33 FILES_jucedemo = "${bindir}"