1 DESCRIPTION
= "A full featured personal video recorder system."
2 HOMEPAGE
= "http://www.mythtv.org"
4 SECTION
= "x11/multimedia"
5 DEPENDS
= "jack alsa-lib libxinerama libxv libxxf86vm libxvmc lirc pulseaudio \
6 ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'lame', d)}"
7 RDEPENDS_$
{PN
} = "libmyth mythtv-backend mythtv-frontend mythtv-bin mythtv-filters mythtv-database \
8 mysql5-server mysql5-client libmysqlclient qt4-plugin-sqldriver-sqlmysql xmltv"
9 #RDEPENDS_$
{PN
} = "qt-x11-plugins-sqldrivers qt-x11-plugins-imageformats"
10 RDEPENDS_$
{PN
}_append_libc
-glibc
= " glibc-gconv-utf-16"
12 ARM_INSTRUCTION_SET
= "arm"
14 QMAKE_PROFILES
= "mythtv.pro"
16 PR
= "svnr${SRCPV}+r0"
19 # REALPV is here
to support release candidates
20 # OE in that
case has as PV something like
0.21+0.22rc1
21 # but
for packaging the real PV is needed
25 SRC_URI
= "svn://svn.mythtv.org/svn/branches/release-0-23-fixes;module=mythtv;proto=http"
27 S
= "${WORKDIR}/mythtv"
29 ALLOW_EMPTY_$
{PN
} = "1"
31 QMAKE_PROFILES
= "mythtv.pro"
34 file://configure.patch \
39 EXTRA_MYTHTVCONF_armv7a
= "--cpu=cortex-a8"
40 EXTRA_MYTHTVCONF_armv5te
= "--cpu=armv5te"
41 EXTRA_MYTHTVCONF ?
= ""
43 --cross-prefix=${TARGET_PREFIX} \
44 --sysroot=${STAGING_DIR_HOST} \
46 --arch=${TARGET_ARCH} \
48 --extra-cflags="$
{TARGET_CFLAGS
} $
{HOST_CC_ARCH
}$
{TOOLCHAIN_OPTIONS
}" \
49 --extra-cxxflags="$
{TARGET_CXXFLAGS
} $
{HOST_CC_ARCH
}$
{TOOLCHAIN_OPTIONS
}" \
50 --extra-ldflags="$
{TARGET_LDFLAGS
}" \
54 do_configure_prepend
() {
55 # it's
not autotools anyway
, so we call .
/configure directly
56 find .
-name
"Makefile"|xargs rm
-f
57 .
/configure
--qmake
=qmake2 \
66 --dvb
-path
=$
{STAGING_INCDIR
} \
67 --without
-bindings
=perl
,python \
72 oe_runmake INSTALL_ROOT
=$
{D
} install
73 install
-d $
{D
}$
{datadir
}/mythtv
74 install
-d $
{D
}$
{datadir
}/mythtv
/sql
75 install
-m
0644 $
{S
}/database
/mc.sql $
{D
}$
{datadir
}/mythtv
/sql
78 PACKAGES
=+ "libmyth mythtv-backend mythtv-frontend mythtv-bin mythtv-filters mythtv-database"
79 PACKAGES_DYNAMIC
= "mythtv-theme-*"
81 FILES_libmyth
= "${libdir}/lib*.so.*"
82 FILES_libmyth
-dev
= "${libdir}/lib*.so ${libdir}/lib*.a ${incdir}/*"
83 FILES_libmyth
-dbg
= "${libdir}/.debug
84 FILES_${PN}-dbg += "$
{libdir
}/mythtv
/filters
/.debug
"
85 FILES_mythtv-backend = "$
{bindir
}/mythbackend $
{bindir
}/mythcommflag $
{bindir
}/mythfilldatabase $
{bindir
}/mythtranscode
"
86 FILES_mythtv-frontend = "$
{bindir
}/mythfrontend $
{datadir
}/mythtv
/i18n
/mythfrontend_
* $
{datadir
}/mythtv
/*.ttf
"
87 FILES_mythtv-bin = "$
{bindir
}/*"
88 FILES_mythtv-filters = "$
{libdir
}/mythtv
/filters
/*"
89 FILES_mythtv-database = "$
{datadir
}/mythtv
/sql
/"
91 RRECOMMENDS_mythtv-frontend += "mythtv
-theme
-defaultmenu mythtv
-theme
-terra
"
93 mythlibs = "mythdb mythavutil mythavcodec mythavformat mythswscale mythhdhomerun myth mythtv mythui mythfreemheg mythupnp mythlivemedia
"
95 python populate_packages_prepend () {
97 def the_hook(file, pkg, pattern, format, basename):
98 new_packages.append(pkg)
99 do_split_packages(d, root=bb.data.expand('${datadir}/mythtv/themes', d), file_regex='(.*)', output_pattern='mythtv-theme-%s', description='MythTV theme %s', allow_dirs=True, hook=the_hook, prepend=True)
100 bb.data.setVar("RDEPENDS_$
{PN
}", "%s
%s
" % (bb.data.getVar("RDEPENDS_$
{PN
}", d), " ".join(new_packages)), d)