1 HOMEPAGE
= "http://www.nazgul.ch/dev_nostromo.html"
4 SRC_URI
= "http://www.nazgul.ch/dev/${PN}-${PV}.tar.gz \
11 TARGET_CC_ARCH
+= "${LDFLAGS}"
17 INITSCRIPT_NAME
= "nostromo"
18 INITSCRIPT_PARAMS
= "defaults 70"
25 install
-d $
{D
}/$
{sbindir
}
26 install
-m
0755 src
/nhttpd
/nhttpd $
{D
}/$
{sbindir
}/nhttpd
27 install
-m
0755 src
/tools
/crypt $
{D
}/$
{sbindir
}/crypt
28 install
-d $
{D
}/$
{mandir
}/man8
29 install
-m
0444 src
/nhttpd
/nhttpd
.8 $
{D
}/$
{mandir
}/man8
/nhttpd
.8
30 install
-d $
{D
}$
{localstatedir
}/nostromo
/conf
31 install
-d $
{D
}$
{localstatedir
}/nostromo
/htdocs
/cgi
-bin
32 install
-d $
{D
}$
{localstatedir
}/nostromo
/icons
33 install
-d $
{D
}$
{localstatedir
}/log/nostromo
34 install
-d $
{D
}$
{localstatedir
}/run
/nostromo
35 install
-d $
{D
}$
{sysconfdir
}/init.d
36 install
-m
0644 conf
/mimes $
{D
}$
{localstatedir
}/nostromo
/conf
/mimes
37 install
-m
0644 $
{WORKDIR
}/nhttpd.conf $
{D
}$
{sysconfdir
}
38 install
-m
0755 $
{WORKDIR
}/nostromo $
{D
}$
{sysconfdir
}/init.d
39 install
-c
-D
-m
644 $
{WORKDIR
}/volatiles $
{D
}$
{sysconfdir
}/default/volatiles
/nostromo
40 install
-m
0644 htdocs
/index.html $
{D
}$
{localstatedir
}/nostromo
/htdocs
/index.html
41 install
-m
0644 htdocs
/nostromo.gif $
{D
}$
{localstatedir
}/nostromo
/htdocs
/nostromo.gif
42 install
-m
0644 icons
/dir.gif $
{D
}$
{localstatedir
}/nostromo
/icons
/dir.gif
43 install
-m
0644 icons
/file.gif $
{D
}$
{localstatedir
}/nostromo
/icons
/file.gif
46 pkg_postinst_$
{PN
}_prepend
() {
47 chown
-R www
-data:www
-data $
{localstatedir
}/nostromo $
{localstatedir
}/log/nostromo $
{localstatedir
}/run
/nostromo
48 /etc
/init.d
/populate
-volatile.sh update
51 SRC_URI
[md5sum
] = "a6971aeb687282b59d0c89530f5b18a6"
52 SRC_URI
[sha256sum
] = "936b9042094201228159f9dba1876bf3f365f50e159769e1d5445b51bda7b8ee"
54 CONFFILES_$
{PN
} += "/var/nostromo/conf/mimes ${sysconfdir}/nhttpd.conf"