cornucopia: bump SRCREV
[openembedded.git] / recipes / ntop / ntop_3.0.bb
blobd8f4426b8bb9cfbaa64bfd25c2806bcdb9055191
1 LICENSE = "GPL"
2 DESCRIPTION = "ntop is network top"
3 SECTION = "console/network"
4 PRIORITY = "optional"
5 DEPENDS = "gdbm zlib libpcap libpng gd"
6 PR = "r1"
8 SRC_URI = "${SOURCEFORGE_MIRROR}/ntop/ntop-${PV}.tgz \
9 file://autotools.patch \
10 file://plugins.patch"
12 inherit autotools
14 EXTRA_OECONF += " --without-ssl \
15 --with-gd-lib=${STAGING_LIBDIR} \
16 --with-gd-include=${STAGING_INCDIR} \
17 --with-zlib-lib=${STAGING_LIBDIR} \
18 --with-zlib-include=${STAGING_INCDIR} \
19 --with-pcap-lib=${STAGING_LIBDIR} \
20 --with-pcap-include=${STAGING_INCDIR} \
21 --with-libpng-lib=${STAGING_LIBDIR} \
22 --with-libpng-include=${STAGING_INCDIR} \
23 --with-gdbm-lib=${STAGING_LIBDIR} \
24 --with-gdbm-include=${STAGING_INCDIR}"
26 FILES_ntop_append = " ${libdir}/ntop/plugins/*.so ${libdir}/libntop-*.so \
27 ${libdir}/libntopreport-*.so"
28 FILES_${PN}-dev = "${includedir} ${libdir}/libntop.so ${libdir}/libntopreport.so \
29 ${libdir}/*.a ${libdir}/libntopreport.a ${libdir}/*.la"
30 FILES_${PN}-dbg += "${libdir}/ntop/plugins/.debug"
32 do_configure_prepend () {
33 if [ ! -e acinclude.m4 ]; then
34 mv acinclude.m4.ntop acinclude.m4
36 rm -f libtool
37 cp ${STAGING_BINDIR_NATIVE}/${TARGET_SYS}-libtool libtool
40 SRC_URI[md5sum] = "1ec6055c75f1acbb5d5600492481ef85"
41 SRC_URI[sha256sum] = "c50cdf2c6cf7309f88c7ec0a56158eca76c80532502b36f3378eeca433423d83"