cornucopia: bump SRCREV
[openembedded.git] / recipes / opencv / openscenegraph_2.9.6.bb
blobc9c8d57a389bb658173bc260f460c3fa922f2ce3
1 DESCRIPTION = "The OpenSceneGraph is an open source high performance 3D graphics toolkit"
2 LICENSE = "OSGPL"
4 DEPENDS = "libxml2 gtk+ ffmpeg poppler libxrandr"
6 PR = "r2"
8 inherit cmake
10 SRC_URI = "http://www.openscenegraph.org/downloads/developer_releases/OpenSceneGraph-2.9.6.zip;name=osg \
11 file://gles.diff "
13 SRC_URI[osg.md5sum] = "f27a69499f3eadf1d8ad2ee22f6d5e85"
14 SRC_URI[osg.sha256sum] = "9aa8ce2a581d42f8c9bac14dff5069c66633ddf73370a1e7412873048d643e9a"
16 S = "${WORKDIR}/OpenSceneGraph-${PV}"
18 # From http://www.openscenegraph.org/projects/osg/wiki/Community/OpenGL-ES
19 EXTRA_OECMAKE = " -DCMAKE_BUILD_TYPE=Release \
20 -DOSG_GLU_AVAILABLE=OFF \
21 -DOSG_GL1_AVAILABLE=OFF \
22 -DOSG_GL2_AVAILABLE=OFF \
23 -DOSG_GL3_AVAILABLE=OFF \
24 -DOSG_GLES1_AVAILABLE=OFF \
25 -DOSG_GLES2_AVAILABLE=ON \
26 -DOPENGL_egl_LIBRARY='-lEGL -lGLESv2 -lGLES_CM -lIMGegl -lsrv_um' \
27 -DOPENGL_LIBRARY='-lGLESv2 -lGLES_CM -lIMGegl -lsrv_um' \
28 -DOSG_GL_DISPLAYLISTS_AVAILABLE=OFF \
29 -DOSG_GL_MATRICES_AVAILABLE=OFF \
30 -DOSG_GL_VERTEX_FUNCS_AVAILABLE=OFF \
31 -DOSG_GL_VERTEX_ARRAY_FUNCS_AVAILABLE=OFF \
32 -DOSG_GL_FIXED_FUNCTION_AVAILABLE=OFF \
33 -DOSG_CPP_EXCEPTIONS_AVAILABLE=OFF \
34 -DPOPPLER_HAS_CAIRO_EXITCODE=0 \
37 TARGET_CC_ARCH += "-D__STDC_CONSTANT_MACROS"
39 FILES_${PN} = " ${bindir}/* ${libdir}/osgPlugins-${PV}/*.so "
40 FILES_${PN}-dbg += "${libdir}/osgPlugins-${PV}/.debug"
42 python populate_packages_prepend () {
43 glibdir = bb.data.expand('${libdir}', d)
45 do_split_packages(d, glibdir, '^lib(.*)\.so\.*', 'lib%s', 'OpenSceneGraph %s library', extra_depends='', allow_links=True)
48 ALLOW_EMPTY = "1"