cornucopia: bump SRCREV
[openembedded.git] / recipes / openjdk-langtools / openjdk-langtools-native_0.0+jdk7-b31.bb
blob39b6dd9c54bd9d614cb0e49169530cbf385d08bd
1 DESCRIPTION = "Java Language tools (sun-javac, javah, javap, javadoc and apt) from OpenJDK"
2 HOMEPAGE = "http://http://openjdk.java.net/groups/compiler"
3 LICENSE = "GPL"
5 PR = "r3"
7 DEPENDS = "classpath-native fastjar-native ecj-initial virtual/java-native"
9 S = "${WORKDIR}/icepick-0.0+hg20080118"
11 SRC_URI = "\
12 http://jalimo.evolvis.org/repository/sources/icepick-0.0+hg20080118.tar.bz2;name=archive \
13 http://jalimo.evolvis.org/repository/sources/openjdk-langtools-jdk7-b31.tar.bz2;name=langtools \
14 file://${PV}-build-fix.patch \
17 inherit java autotools native
19 EXTRA_OECONF = "\
20 --with-javac=${STAGING_BINDIR}/ecj-initial \
21 --with-vm=${STAGING_BINDIR}/java \
22 --with-fastjar=${STAGING_BINDIR}/fastjar \
23 --with-classpath=${STAGING_DATADIR}/classpath/glibj.zip \
24 --with-langtools-src-dir=${WORKDIR}/openjdk-langtools-jdk7-b31 \
27 export JAVAC_OPTS="-bootclasspath ${STAGING_DATADIR_JAVA}/share/classpath/glibj.zip -source 5.0"
29 do_stage() {
30 # Do install step manually to fine control installation names.
31 install -d ${bindir}
32 install -m 0755 tools/apt ${bindir}
33 install -m 0755 tools/javadoc ${bindir}
34 install -m 0755 tools/javah ${bindir}
35 install -m 0755 tools/javap ${bindir}
37 # Provide javac as sun-javac to not clash with the binary of the same
38 # name in ecj-bootstrap-native.
39 # This way ecj-bootstrap-native and openjdk-langtools-native can coexist
40 # in staging dir.
41 install -m 0755 tools/javac ${bindir}/sun-javac
43 install -d ${libdir}
44 install -m 0644 tools.jar ${libdir}
47 SRC_URI[archive.md5sum] = "ce7b1827e6f4cbe73b9ffa90b0d45a6a"
48 SRC_URI[archive.sha256sum] = "63170836095f8451498c813a1f93a9ec70a1164d82aa30650c0f2216ca4377ab"
49 SRC_URI[langtools.md5sum] = "670931f67b2e4ac46c6e0cd15418f2fa"
50 SRC_URI[langtools.sha256sum] = "f8b8820e410c137d279d14dec7e7a93217cc371acdfe1b3343b2278d1728932e"