cornucopia: bump SRCREV
[openembedded.git] / recipes / pad / pad-native.bb
blobcc1f7aa40527b7b88b1bacfbf0953e18eb57b2d8
1 SECTION = "console/utils"
2 DESCRIPTION = "Console utility for padding a file (filling with 0 to reach a specified length)"
3 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/pad"
4 SRC_URI = "file://pad.c"
5 LICENSE = "PD"
6 PR = "r1"
7 inherit native
9 do_compile() {
10 cp ${WORKDIR}/pad.c .
11 ${CC} -I. -o pad pad.c
14 do_install() {
15 install -d ${D}${bindir}/
16 install -m 0755 pad ${D}${bindir}/
19 NATIVE_INSTALL_WORKS = "1"