cornucopia: bump SRCREV
[openembedded.git] / recipes / proftpd / proftpd_1.3.3c.bb
blob465ecbb57a6983a042b9cf65337870186d793e63
1 DESCRIPTION = "Secure ftp daemon"
2 SECTION = "console/network"
3 LICENSE = "GPL"
4 PR = "r0"
6 SRC_URI = "ftp://ftp.nl.uu.net/pub/unix/ftp/proftpd/ftp/distrib/source/${PN}-${PV}.tar.gz \
7 file://make.patch \
8 file://proftpd-install-nostrip.patch \
10 SRC_URI[md5sum] = "4f2c554d6273b8145095837913ba9e5d"
11 SRC_URI[sha256sum] = "44be095ed063df93278928cf665ad7b9b38e2c8d0cca97fb51307ec3a390a591"
13 EXTRA_OECONF = "ac_cv_func_setpgrp_void=yes ac_cv_func_setgrent_void=yes --disable-cap"
14 LDFLAGS += "-Llib"
15 PARALLEL_MAKE = ""
17 do_configure () {
18 ./configure \
19 --disable-auth-pam \
20 --build=${BUILD_SYS} \
21 --host=${HOST_SYS} \
22 --target=${TARGET_SYS} \
23 --prefix=/usr \
24 --sysconfdir=/etc \
25 --sharedstatedir=/com \
26 --localstatedir=/var \
27 ${EXTRA_OECONF} \
28 $@;
31 pkg_postinst () {
32 # more chown's might be needed
33 chown root:root /usr/sbin/proftpd