1 DESCRIPTION
= "Robostix programs"
5 RDEPENDS_$
{PN
} = "kernel-${KERNEL_VERSION}"
6 DEPENDS
= "virtual/kernel"
10 SRC_URI
= "svn://svn.gumstix.com/gumstix-buildroot/branches/projects;module=robostix;rev=1588;proto=http \
11 file://makefile-rules.patch \
12 file://gummake.patch \
15 S
= "${WORKDIR}/robostix"
19 EXTRA_OEMAKE
= 'CROSS_COMPILE
="${CROSS_COMPILE}" \
20 KERNELDIR
="${KERNEL_SOURCE}" \
27 echo
"Nothing to configure for robostix"
31 unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
36 cd $
{S
}/gumstix
/i2c
-io
38 cd $
{S
}/gumstix
/i2c
-load
45 # install programs
to bindir
46 install
-m
0755 -d $
{D
}$
{bindir
}
47 install
-m
0755 $
{S
}/gumstix
/i2c
-io
/i2c
-io $
{D
}$
{bindir
}
48 install
-m
0755 $
{S
}/gumstix
/i2c
-load
/i2c
-load $
{D
}$
{bindir
}
49 install
-m
0755 $
{S
}/gumstix
/i2c
/i2c $
{D
}$
{bindir
}
50 install
-m
0755 $
{S
}/gumstix
/robostix $
{D
}$
{bindir
}
51 install
-m
0755 $
{S
}/gumstix
/sertest $
{D
}$
{bindir
}
53 # kernel module installs with other modules
, but use
54 # cp instead of install so its
not stripped
55 install
-m
0755 -d $
{D
}$
{base_libdir
}/modules
/$
{KERNEL_VERSION
}/extra
/
56 cp $
{S
}/gumstix
/robostix_drv.ko $
{D
}$
{base_libdir
}/modules
/$
{KERNEL_VERSION
}/extra
/
58 # avr
hex programs install
to /root
59 install
-m
0755 -d $
{D
}/root
60 install
-m
0755 $
{S
}/ArgTest
/ArgTest.
hex $
{D
}/root
61 install
-m
0755 $
{S
}/Flash
-LED
/Flash
-LED.
hex $
{D
}/root
62 install
-m
0755 $
{S
}/i2c
-BootLoader
/i2c
-Boot
-m128
-16MHz.
hex $
{D
}/root
63 install
-m
0755 $
{S
}/i2c
-BootLoader
/i2c
-Boot
-m128
-16MHz
-eep.
hex $
{D
}/root
64 install
-m
0755 $
{S
}/i2c
-io
/i2c
-io.
hex $
{D
}/root
65 install
-m
0755 $
{S
}/i2c
-test
/i2c
-test.
hex $
{D
}/root
66 install
-m
0755 $
{S
}/int6
/int6.
hex $
{D
}/root
67 install
-m
0755 $
{S
}/LCD
-Test
/LCD
-Test.
hex $
{D
}/root
68 install
-m
0755 $
{S
}/QD
-Test
/QD
-Test.
hex $
{D
}/root
69 install
-m
0755 $
{S
}/RCInput
/RC
-Test.
hex $
{D
}/root
70 install
-m
0755 $
{S
}/Simple
-Flasher
/Simple
-Flasher.
hex $
{D
}/root
71 install
-m
0755 $
{S
}/Simple
-Servo
/Simple
-Servo.
hex $
{D
}/root
72 install
-m
0755 $
{S
}/Simple
-Servo
-2/Simple
-Servo
-2.
hex $
{D
}/root
73 install
-m
0755 $
{S
}/Tachometer
/Tachometer.
hex $
{D
}/root
76 PACKAGES
= "${PN}-i2c-io"
77 FILES_$
{PN
}-i2c
-io
= "${bindir}/i2c-io"
79 PACKAGES
+= "${PN}-i2c-load"
80 FILES_$
{PN
}-i2c
-load
= "${bindir}/i2c-load"
82 PACKAGES
+= "${PN}-i2c"
83 FILES_$
{PN
}-i2c
= "${bindir}/i2c"
85 PACKAGES
+= "${PN}-sertest"
86 FILES_$
{PN
}-sertest
= "${bindir}/sertest"
88 PACKAGES
+= "${PN}-usermode"
89 FILES_$
{PN
}-usermode
= "${bindir}/robostix"
91 PACKAGES
+= "${PN}-kernel-module"
92 FILES_$
{PN
}-kernel
-module
= "${base_libdir}/modules/${KERNEL_VERSION}/extra/robostix_drv.ko"
94 PACKAGES
+= "${PN}-avr-ArgTest"
95 FILES_$
{PN
}-avr
-ArgTest
= "/root/ArgTest.hex"
97 PACKAGES
+= "${PN}-avr-Flash-LED"
98 FILES_$
{PN
}-avr
-Flash
-LED
= "/root/Flash-LED.hex"
100 PACKAGES
+= "${PN}-avr-i2c-BootLoader"
101 FILES_$
{PN
}-avr
-i2c
-BootLoader
= "/root/i2c-Boot-m128-16MHz.hex"
103 PACKAGES
+= "${PN}-avr-i2c-BootLoader-eep"
104 FILES_$
{PN
}-avr
-i2c
-BootLoader
-eep
= "/root/i2c-Boot-m128-16MHz-eep.hex"
106 PACKAGES
+= "${PN}-avr-i2c-io"
107 FILES_$
{PN
}-avr
-i2c
-io
= "/root/i2c-io.hex"
109 PACKAGES
+= "${PN}-avr-i2c-test"
110 FILES_$
{PN
}-avr
-i2c
-test
= "/root/i2c-test.hex"
112 PACKAGES
+= "${PN}-avr-int6"
113 FILES_$
{PN
}-avr
-int6
= "/root/int6.hex"
115 PACKAGES
+= "${PN}-avr-LCD-Test"
116 FILES_$
{PN
}-avr
-LCD
-Test
= "/root/LCD-Test.hex"
118 PACKAGES
+= "${PN}-avr-QD-Test"
119 FILES_$
{PN
}-avr
-QD
-Test
= "/root/QD-Test.hex"
121 PACKAGES
+= "${PN}-avr-RC-Test"
122 FILES_$
{PN
}-avr
-RC
-Test
= "/root/RC-Test.hex"
124 PACKAGES
+= "${PN}-avr-Simple-Flasher"
125 FILES_$
{PN
}-avr
-Simple
-Flasher
= "/root/Simple-Flasher.hex"
127 PACKAGES
+= "${PN}-avr-Simple-Servo"
128 FILES_$
{PN
}-avr
-Simple
-Servo
= "/root/Simple-Servo.hex"
130 PACKAGES
+= "${PN}-avr-Simple-Servo-2"
131 FILES_$
{PN
}-avr
-Simple
-Servo
-2 = "/root/Simple-Servo-2.hex"
133 PACKAGES
+= "${PN}-avr-Tachometer"
134 FILES_$
{PN
}-avr
-Tachometer
= "/root/Tachometer.hex"