1 DESCRIPTION
= "Commands for Manipulating Filesystem Extended Attributes"
6 SRC_URI
= "http://mirror.its.uidaho.edu/pub/savannah/attr/attr-${PV}.src.tar.gz"
8 inherit gettext autotools lib_package
9 EXTRA_OECONF
= " --enable-gettext=yes \
10 ac_cv_path_XGETTEXT=${STAGING_BINDIR_NATIVE}/xgettext \
11 ac_cv_path_MSGFMT=${STAGING_BINDIR_NATIVE}/msgfmt \
12 ac_cv_path_MSGMERGE=${STAGING_BINDIR_NATIVE}/msgmerge \
16 # Only append ldflags
for target recipe
17 LDFLAGS_libc
-uclibc
+= "${@['', '-lintl']['${PN}' == '${BPN}']}"
19 TOPDIR
[unexport
] = "1"
21 BBCLASSEXTEND
= "native"
23 do_configure_append
() {
25 echo
"#define _(str) str" >> $
{S
}/include/config.h
28 do_configure_prepend_libc
-uclibc
() {
29 eval
"${@base_contains('DISTRO_FEATURES', 'largefile', '', 'sed -i -e "s
/-D_FILE_OFFSET_BITS
=64//" ${S}/include/builddefs.in', d)}"
33 export PKG_BIN_DIR
=$
{D
}$
{bindir
}
34 export PKG_SBIN_DIR
=$
{D
}$
{sbindir
}
35 export PKG_LIB_DIR
=$
{D
}$
{libdir
}
36 export PKG_DEVLIB_DIR
=$
{D
}$
{libexecdir
}
37 export PKG_INC_DIR
=$
{D
}$
{includedir
}/attr
38 export PKG_MAN_DIR
=$
{D
}$
{mandir
}
39 export PKG_DOC_DIR
=$
{D
}$
{datadir
}/doc
/attr
40 export PKG_LOCALE_DIR
=$
{D
}$
{datadir
}/locale
41 # ensure the subdir Makefile do
not use the
(wrong
) variable overrides from the
include file
42 export MAKE
="${MAKE} -e"
44 oe_runmake
-e install install
-dev install
-lib
46 sed
-i
-e s
:installed
=yes
:installed
=no
: -e s
:$
{STAGING_LIBDIR
}:$
{libdir
}:g $
{D
}$
{libdir
}/libattr.la
48 # Move .a
and .la into libdir
and remove symlinks pointing
to $
{S
}
49 for file in $
{D
}$
{libexecdir
}/*a
; do
50 rm $
{D
}$
{libdir
}/$
(basename $file
)
51 mv $file $
{D
}$
{libdir
}
53 rm $
{D
}$
{libexecdir
} -rf
56 SRC_URI
[md5sum
] = "d132c119831c27350e10b9f885711adc"
57 SRC_URI
[sha256sum
] = "9f6214b8e53f4bba651ac5a72c0f6193b12aa21fbf1d675d89a7b4bc45264498"