3 # This spec file was automatically generated by cpan2rpm [ver: 2.027]
4 # The following arguments were used:
5 # --spec-only --version=1.07 '--author=Oded S. Resnik' Data-Password-1.07.tar.gz
6 # For more information on cpan2rpm please visit: http://perl.arix.com/
9 %define pkgname Data
-Password
10 %define filelist
%{pkgname}-%{version}-filelist
11 %define NVR
%{pkgname}-%{version}-%{release}
14 name
: perl
-Data
-Password
15 summary
: Data
-Password
- Perl extension
for assesing password quality.
18 vendor
: Oded S. Resnik
19 packager
: Arix International
<cpan2rpm@arix.com
>
21 group
: Applications
/CPAN
22 url
: http
://www.cpan.org
23 buildroot
: %{_tmppath}/%{name}-%{version}-%
(id
-u
-n
)
25 prefix
: %
(echo %{_prefix})
26 source: Data
-Password
-1.07.tar.gz
29 This modules checks potential passwords
for crackability.
30 It checks that the password is
in the appropriate length
,
31 that it has enough character groups
, that it does not contain the same
32 chars repeatedly or ascending or descending characters
, or charcters
33 close to each other
in the keyboard.
34 It will also attempt to search the ispell word file
for existance
36 The module's policies can be modified by changing its variables.
(Check "VARIABLES"
).
37 For doing it
, it is recommended to import the '
:all' shortcut
40 *use Data
::Password qw
(:all
);*
43 # This package was generated automatically with the cpan2rpm
44 # utility. To get this software or for more information
45 # please visit: http://perl.arix.com/
49 %setup -q
-n
%{pkgname}-%{version}
50 chmod
-R u
+w
%{_builddir}/%{pkgname}-%{version}
53 grep
-rsl '^
#!.*perl' . |
54 grep
-v '.bak$' |xargs
--no
-run
-if-empty \
55 %__perl -MExtUtils
::MakeMaker
-e 'MY
->fixin
(@ARGV
)'
56 CFLAGS
="$RPM_OPT_FLAGS"
57 %{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}|
if \$ExtUtils
::MakeMaker
::VERSION
=~
/5\
.9[1-6]|
6\
.0[0-5]/ '`
64 [ "
%{buildroot}" != "/" ] && rm -rf %{buildroot}
66 %{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '`
68 cmd
=/usr
/share
/spec
-helper
/compress_files
69 [ -x $cmd
] || cmd
=/usr
/lib
/rpm
/brp
-compress
73 if [ -e
/etc
/SuSE
-release
-o
-e
/etc
/UnitedLinux
-release
]
75 %{__mkdir_p} %{buildroot}/var
/adm
/perl
-modules
76 %{__cat} `find %{buildroot} -name "perllocal.pod"` \
77 |
%{__sed} -e s+%{buildroot}++g \
78 > %{buildroot}/var/adm/perl-modules/%{name}
81 # remove special files
82 find
%{buildroot} -name "perllocal.pod" \
83 -o
-name ".packlist" \
87 # no empty directories
88 find
%{buildroot}%{_prefix} \
90 -exec rmdir {} \
; 2>/dev
/null
92 %{__perl} -MFile
::Find
-le '
93 find
({ wanted
=> \
&wanted
, no_chdir
=> 1}, "
%{buildroot}"
);
94 print "
%doc Changes README"
;
95 for my $x
(sort @
dirs, @files
) {
96 push @ret
, $x unless indirs
($x
);
98 print join "\n"
, sort @ret
;
103 local $_
= $File
::Find
::name
;
104 my $f
= $_
; s|^\Q
%{buildroot}\E||
;
105 return unless length
;
106 return $files
[@files
] = $_
if -f $f
;
109 /\Q$d\E
/ && return for reverse sort @INC
;
110 $d
=~
/\Q$_\E
/ && return
111 for qw|
/etc
%_prefix/man
%_prefix/bin
%_prefix/share|
;
118 $x
=~
/^\Q$_\E\
// && $x ne $_
&& return 1 for @
dirs;
122 [ -z
%filelist ] && {
123 echo "ERROR
: empty
%files listing"
128 [ "
%{buildroot}" != "/" ] && rm -rf %{buildroot}
131 %defattr(-,root
,root
)
134 * Wed Dec
6 2006 root@dca02