3 # This spec file was automatically generated by cpan2rpm [ver: 2.027]
4 # The following arguments were used:
5 # --spec-only --version=0.32 '--author=Dave Rolsky' DateTime-Locale-0.32.tar.gz
6 # For more information on cpan2rpm please visit: http://perl.arix.com/
9 %define pkgname DateTime
-Locale
10 %define filelist
%{pkgname}-%{version}-filelist
11 %define NVR
%{pkgname}-%{version}-%{release}
14 name
: perl
-DateTime
-Locale
15 summary
: DateTime
-Locale
- Perl module
19 packager
: Arix International
<cpan2rpm@arix.com
>
21 group
: Applications
/CPAN
22 url
: http
://www.cpan.org
23 buildroot
: %{_tmppath}/%{name}-%{version}-%
(id
-u
-n
)
25 prefix
: %
(echo %{_prefix})
26 source: DateTime
-Locale
-0.32.tar.gz
32 # This package was generated automatically with the cpan2rpm
33 # utility. To get this software or for more information
34 # please visit: http://perl.arix.com/
38 %setup -q
-n
%{pkgname}-%{version}
39 chmod
-R u
+w
%{_builddir}/%{pkgname}-%{version}
42 grep
-rsl '^
#!.*perl' . |
43 grep
-v '.bak$' |xargs
--no
-run
-if-empty \
44 %__perl -MExtUtils
::MakeMaker
-e 'MY
->fixin
(@ARGV
)'
52 [ "
%{buildroot}" != "/" ] && rm -rf %{buildroot}
54 %{__perl} Build install destdir=%{buildroot}
56 cmd
=/usr
/share
/spec
-helper
/compress_files
57 [ -x $cmd
] || cmd
=/usr
/lib
/rpm
/brp
-compress
61 if [ -e
/etc
/SuSE
-release
-o
-e
/etc
/UnitedLinux
-release
]
63 %{__mkdir_p} %{buildroot}/var
/adm
/perl
-modules
64 %{__cat} `find %{buildroot} -name "perllocal.pod"` \
65 |
%{__sed} -e s+%{buildroot}++g \
66 > %{buildroot}/var/adm/perl-modules/%{name}
69 # remove special files
70 find
%{buildroot} -name "perllocal.pod" \
71 -o
-name ".packlist" \
75 # no empty directories
76 find
%{buildroot}%{_prefix} \
78 -exec rmdir {} \
; 2>/dev
/null
80 %{__perl} -MFile
::Find
-le '
81 find
({ wanted
=> \
&wanted
, no_chdir
=> 1}, "
%{buildroot}"
);
82 print "
%doc tools LICENSE.cldr Changes README LICENSE"
;
83 for my $x
(sort @
dirs, @files
) {
84 push @ret
, $x unless indirs
($x
);
86 print join "\n"
, sort @ret
;
91 local $_
= $File
::Find
::name
;
92 my $f
= $_
; s|^\Q
%{buildroot}\E||
;
94 return $files
[@files
] = $_
if -f $f
;
97 /\Q$d\E
/ && return for reverse sort @INC
;
98 $d
=~
/\Q$_\E
/ && return
99 for qw|
/etc
%_prefix/man
%_prefix/bin
%_prefix/share|
;
106 $x
=~
/^\Q$_\E\
// && $x ne $_
&& return 1 for @
dirs;
110 [ -z
%filelist ] && {
111 echo "ERROR
: empty
%files listing"
116 [ "
%{buildroot}" != "/" ] && rm -rf %{buildroot}
119 %defattr(-,root
,root
)
122 * Thu Nov
23 2006 root@dca02