3 # This spec file was automatically generated by cpan2rpm [ver: 2.027]
4 # The following arguments were used:
5 # --spec-only --version=1.04 '--author=Sean M. Burke' Pod-Escapes-1.04.tar.gz
6 # For more information on cpan2rpm please visit: http://perl.arix.com/
9 %define pkgname Pod
-Escapes
10 %define filelist
%{pkgname}-%{version}-filelist
11 %define NVR
%{pkgname}-%{version}-%{release}
14 name
: perl
-Pod
-Escapes
15 summary
: Pod
-Escapes
- - for resolving Pod E
<...
> sequences
19 packager
: Arix International
<cpan2rpm@arix.com
>
21 group
: Applications
/CPAN
22 url
: http
://www.cpan.org
23 buildroot
: %{_tmppath}/%{name}-%{version}-%
(id
-u
-n
)
25 prefix
: %
(echo %{_prefix})
26 source: Pod
-Escapes
-1.04.tar.gz
29 This module provides things that are useful
in decoding
30 Pod E
<...
> sequences. Presumably
, it should be used
31 only by Pod parsers and
/or formatters.
33 By default
, Pod
::Escapes exports none of its symbols. But
34 you can request any of them to be exported.
35 Either request them individually
, as with
36 "use Pod
::Escapes qw
(symbolname symbolname2...
);"
,
37 or you can
do "use Pod
::Escapes qw
(:ALL
);" to get all
41 # This package was generated automatically with the cpan2rpm
42 # utility. To get this software or for more information
43 # please visit: http://perl.arix.com/
47 %setup -q
-n
%{pkgname}-%{version}
48 chmod
-R u
+w
%{_builddir}/%{pkgname}-%{version}
51 grep
-rsl '^
#!.*perl' . |
52 grep
-v '.bak$' |xargs
--no
-run
-if-empty \
53 %__perl -MExtUtils
::MakeMaker
-e 'MY
->fixin
(@ARGV
)'
54 CFLAGS
="$RPM_OPT_FLAGS"
55 %{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}|
if \$ExtUtils
::MakeMaker
::VERSION
=~
/5\
.9[1-6]|
6\
.0[0-5]/ '`
62 [ "
%{buildroot}" != "/" ] && rm -rf %{buildroot}
64 %{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '`
66 cmd
=/usr
/share
/spec
-helper
/compress_files
67 [ -x $cmd
] || cmd
=/usr
/lib
/rpm
/brp
-compress
71 if [ -e
/etc
/SuSE
-release
-o
-e
/etc
/UnitedLinux
-release
]
73 %{__mkdir_p} %{buildroot}/var
/adm
/perl
-modules
74 %{__cat} `find %{buildroot} -name "perllocal.pod"` \
75 |
%{__sed} -e s+%{buildroot}++g \
76 > %{buildroot}/var/adm/perl-modules/%{name}
79 # remove special files
80 find
%{buildroot} -name "perllocal.pod" \
81 -o
-name ".packlist" \
85 # no empty directories
86 find
%{buildroot}%{_prefix} \
88 -exec rmdir {} \
; 2>/dev
/null
90 %{__perl} -MFile
::Find
-le '
91 find
({ wanted
=> \
&wanted
, no_chdir
=> 1}, "
%{buildroot}"
);
93 for my $x
(sort @
dirs, @files
) {
94 push @ret
, $x unless indirs
($x
);
96 print join "\n"
, sort @ret
;
101 local $_
= $File
::Find
::name
;
102 my $f
= $_
; s|^\Q
%{buildroot}\E||
;
103 return unless length
;
104 return $files
[@files
] = $_
if -f $f
;
107 /\Q$d\E
/ && return for reverse sort @INC
;
108 $d
=~
/\Q$_\E
/ && return
109 for qw|
/etc
%_prefix/man
%_prefix/bin
%_prefix/share|
;
116 $x
=~
/^\Q$_\E\
// && $x ne $_
&& return 1 for @
dirs;
120 [ -z
%filelist ] && {
121 echo "ERROR
: empty
%files listing"
126 [ "
%{buildroot}" != "/" ] && rm -rf %{buildroot}
129 %defattr(-,root
,root
)
132 * Thu Nov
23 2006 root@dca02