RT notifier: parse templates without header correctly
[openxpki.git] / trunk / package / suse / external-dependencies / Pod-Simple.spec
blob92ea0669d4ab46a31db45822cb485bf1f2fe4409
2 # - Pod::Simple -
3 # This spec file was automatically generated by cpan2rpm [ver: 2.027]
4 # The following arguments were used:
5 # --spec-only --version=3.04 '--author=Allison Randal' Pod-Simple-3.04.tar.gz
6 # For more information on cpan2rpm please visit: http://perl.arix.com/
9 %define pkgname Pod-Simple
10 %define filelist %{pkgname}-%{version}-filelist
11 %define NVR %{pkgname}-%{version}-%{release}
12 %define maketest 1
14 name: perl-Pod-Simple
15 summary: Pod-Simple - framework for parsing Pod
16 version: 3.04
17 release: 1
18 vendor: Allison Randal
19 packager: Arix International <cpan2rpm@arix.com>
20 license: Artistic
21 group: Applications/CPAN
22 url: http://www.cpan.org
23 buildroot: %{_tmppath}/%{name}-%{version}-%(id -u -n)
24 buildarch: noarch
25 prefix: %(echo %{_prefix})
26 source: Pod-Simple-3.04.tar.gz
28 %description
29 Pod::Simple is a Perl library for parsing text in the Pod ("plain old
30 documentation") markup language that is typically used for writing
31 documentation for Perl and for Perl modules. The Pod format is explained
32 in the perlpod man page; the most common formatter is called
33 "perldoc".
35 Pod formatters can use Pod::Simple to parse Pod documents into produce
36 renderings of them in plain ASCII, in HTML, or in any number of other
37 formats. Typically, such formatters will be subclasses of Pod::Simple,
38 and so they will inherit its methods, like "parse_file".
40 If you're reading this document just because you have a Pod-processing
41 subclass that you want to use, this document (plus the documentation for
42 the subclass) is probably all you'll need to read.
44 If you're reading this document because you want to write a formatter
45 subclass, continue reading this document, and then read
46 Pod::Simple::Subclassing, and then possibly even read perlpodspec
47 (some of which is for parser-writers, but much of which is notes to
48 formatter-writers).
51 # This package was generated automatically with the cpan2rpm
52 # utility. To get this software or for more information
53 # please visit: http://perl.arix.com/
56 %prep
57 %setup -q -n %{pkgname}-%{version}
58 chmod -R u+w %{_builddir}/%{pkgname}-%{version}
60 %build
61 grep -rsl '^#!.*perl' . |
62 grep -v '.bak$' |xargs --no-run-if-empty \
63 %__perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)'
64 CFLAGS="$RPM_OPT_FLAGS"
65 %{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}| if \$ExtUtils::MakeMaker::VERSION =~ /5\.9[1-6]|6\.0[0-5]/ '`
66 %{__make}
67 %if %maketest
68 %{__make} test
69 %endif
71 %install
72 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
74 %{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '`
76 cmd=/usr/share/spec-helper/compress_files
77 [ -x $cmd ] || cmd=/usr/lib/rpm/brp-compress
78 [ -x $cmd ] && $cmd
80 # SuSE Linux
81 if [ -e /etc/SuSE-release -o -e /etc/UnitedLinux-release ]
82 then
83 %{__mkdir_p} %{buildroot}/var/adm/perl-modules
84 %{__cat} `find %{buildroot} -name "perllocal.pod"` \
85 | %{__sed} -e s+%{buildroot}++g \
86 > %{buildroot}/var/adm/perl-modules/%{name}
89 # remove special files
90 find %{buildroot} -name "perllocal.pod" \
91 -o -name ".packlist" \
92 -o -name "*.bs" \
93 |xargs -i rm -f {}
95 # no empty directories
96 find %{buildroot}%{_prefix} \
97 -type d -depth \
98 -exec rmdir {} \; 2>/dev/null
100 %{__perl} -MFile::Find -le '
101 find({ wanted => \&wanted, no_chdir => 1}, "%{buildroot}");
102 print "%doc README";
103 for my $x (sort @dirs, @files) {
104 push @ret, $x unless indirs($x);
106 print join "\n", sort @ret;
108 sub wanted {
109 return if /auto$/;
111 local $_ = $File::Find::name;
112 my $f = $_; s|^\Q%{buildroot}\E||;
113 return unless length;
114 return $files[@files] = $_ if -f $f;
116 $d = $_;
117 /\Q$d\E/ && return for reverse sort @INC;
118 $d =~ /\Q$_\E/ && return
119 for qw|/etc %_prefix/man %_prefix/bin %_prefix/share|;
121 $dirs[@dirs] = $_;
124 sub indirs {
125 my $x = shift;
126 $x =~ /^\Q$_\E\// && $x ne $_ && return 1 for @dirs;
128 ' > %filelist
130 [ -z %filelist ] && {
131 echo "ERROR: empty %files listing"
132 exit -1
135 %clean
136 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
138 %files -f %filelist
139 %defattr(-,root,root)
141 %changelog
142 * Thu Nov 23 2006 root@dca02
143 - Initial build.