3 # This spec file was automatically generated by cpan2rpm [ver: 2.027]
4 # The following arguments were used:
5 # --spec-only --version=2.15 '--author=Andy Wardley' Template-Toolkit-2.15.tar.gz
6 # For more information on cpan2rpm please visit: http://perl.arix.com/
9 %define pkgname Template
-Toolkit
10 %define filelist
%{pkgname}-%{version}-filelist
11 %define NVR
%{pkgname}-%{version}-%{release}
14 name
: perl
-Template
-Toolkit
15 summary
: Template
-Toolkit
- comprehensive template processing system
19 packager
: Arix International
<cpan2rpm@arix.com
>
21 group
: Applications
/CPAN
22 url
: http
://www.cpan.org
23 buildroot
: %{_tmppath}/%{name}-%{version}-%
(id
-u
-n
)
24 prefix
: %
(echo %{_prefix})
25 source: Template
-Toolkit
-2.15.tar.gz
28 This documentation describes the Template module which is the direct
29 Perl interface into the Template Toolkit. It covers the use of the
30 module and gives a brief summary of configuration options and template
31 directives. Please see Template
::Manual
for the complete reference
32 manual which goes into much greater depth about the features and use
33 of the Template Toolkit. The Template
::Tutorial is also available
34 as an introductory guide to using the Template Toolkit.
37 # This package was generated automatically with the cpan2rpm
38 # utility. To get this software or for more information
39 # please visit: http://perl.arix.com/
43 %setup -q
-n
%{pkgname}-%{version}
44 chmod
-R u
+w
%{_builddir}/%{pkgname}-%{version}
47 grep
-rsl '^
#!.*perl' . |
48 grep
-v '.bak$' |xargs
--no
-run
-if-empty \
49 %__perl -MExtUtils
::MakeMaker
-e 'MY
->fixin
(@ARGV
)'
50 CFLAGS
="$RPM_OPT_FLAGS"
51 %{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}|
if \$ExtUtils
::MakeMaker
::VERSION
=~
/5\
.9[1-6]|
6\
.0[0-5]/ '`
58 [ "
%{buildroot}" != "/" ] && rm -rf %{buildroot}
60 %{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '`
62 cmd
=/usr
/share
/spec
-helper
/compress_files
63 [ -x $cmd
] || cmd
=/usr
/lib
/rpm
/brp
-compress
67 if [ -e
/etc
/SuSE
-release
-o
-e
/etc
/UnitedLinux
-release
]
69 %{__mkdir_p} %{buildroot}/var
/adm
/perl
-modules
70 %{__cat} `find %{buildroot} -name "perllocal.pod"` \
71 |
%{__sed} -e s+%{buildroot}++g \
72 > %{buildroot}/var/adm/perl-modules/%{name}
75 # remove special files
76 find
%{buildroot} -name "perllocal.pod" \
77 -o
-name ".packlist" \
81 # no empty directories
82 find
%{buildroot}%{_prefix} \
84 -exec rmdir {} \
; 2>/dev
/null
86 %{__perl} -MFile
::Find
-le '
87 find
({ wanted
=> \
&wanted
, no_chdir
=> 1}, "
%{buildroot}"
);
88 print "
%doc images TODO bin parser xs Changes INSTALL docs templates README examples"
;
89 for my $x
(sort @
dirs, @files
) {
90 push @ret
, $x unless indirs
($x
);
92 print join "\n"
, sort @ret
;
97 local $_
= $File
::Find
::name
;
98 my $f
= $_
; s|^\Q
%{buildroot}\E||
;
100 return $files
[@files
] = $_
if -f $f
;
103 /\Q$d\E
/ && return for reverse sort @INC
;
104 $d
=~
/\Q$_\E
/ && return
105 for qw|
/etc
%_prefix/man
%_prefix/bin
%_prefix/share|
;
112 $x
=~
/^\Q$_\E\
// && $x ne $_
&& return 1 for @
dirs;
116 [ -z
%filelist ] && {
117 echo "ERROR
: empty
%files listing"
122 [ "
%{buildroot}" != "/" ] && rm -rf %{buildroot}
125 %defattr(-,root
,root
)
128 * Thu Dec
21 2006 root@dca02