2 # - XML::Filter::BufferText -
5 %define pkgname XML
-Filter
-BufferText
6 %define filelist
%{pkgname}-%{version}-filelist
7 %define NVR
%{pkgname}-%{version}-%{release}
10 name
: perl
-XML
-Filter
-BufferText
11 summary
: XML
-Filter
-BufferText
- Filter to put all characters
() in one event
15 packager
: Arix International
<cpan2rpm@arix.com
>
17 group
: Applications
/CPAN
18 url
: http
://www.cpan.org
19 buildroot
: %{_tmppath}/%{name}-%{version}-%
(id
-u
-n
)
21 prefix
: %
(echo %{_prefix})
22 source: XML
-Filter
-BufferText
-1.01.tar.gz
25 This is a very simple filter. One common cause of grief
(and programmer
26 error
) is that XML parsers aren't required to provide character events
in one
27 chunk. They can
, but are not forced to
, and most don't. This filter does the
28 trivial but oft
-repeated task of putting all characters into a single event.
31 # This package was generated automatically with the cpan2rpm
32 # utility. To get this software or for more information
33 # please visit: http://perl.arix.com/
37 %setup -q
-n
%{pkgname}-%{version}
38 chmod
-R u
+w
%{_builddir}/%{pkgname}-%{version}
41 grep
-rsl '^
#!.*perl' . |
42 grep
-v '.bak$' |xargs
--no
-run
-if-empty \
43 %__perl -MExtUtils
::MakeMaker
-e 'MY
->fixin
(@ARGV
)'
44 CFLAGS
="$RPM_OPT_FLAGS"
45 %{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}|
if \$ExtUtils
::MakeMaker
::VERSION
=~
/5\
.9[1-6]|
6\
.0[0-5]/ '`
52 [ "
%{buildroot}" != "/" ] && rm -rf %{buildroot}
54 %{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '`
56 cmd
=/usr
/share
/spec
-helper
/compress_files
57 [ -x $cmd
] || cmd
=/usr
/lib
/rpm
/brp
-compress
61 if [ -e
/etc
/SuSE
-release
-o
-e
/etc
/UnitedLinux
-release
]
63 %{__mkdir_p} %{buildroot}/var
/adm
/perl
-modules
64 %{__cat} `find %{buildroot} -name "perllocal.pod"` \
65 |
%{__sed} -e s+%{buildroot}++g \
66 > %{buildroot}/var/adm/perl-modules/%{name}
69 # remove special files
70 find
%{buildroot} -name "perllocal.pod" \
71 -o
-name ".packlist" \
75 # no empty directories
76 find
%{buildroot}%{_prefix} \
78 -exec rmdir {} \
; 2>/dev
/null
80 %{__perl} -MFile
::Find
-le '
81 find
({ wanted
=> \
&wanted
, no_chdir
=> 1}, "
%{buildroot}"
);
82 print "
%doc Changes README"
;
83 for my $x
(sort @
dirs, @files
) {
84 push @ret
, $x unless indirs
($x
);
86 print join "\n"
, sort @ret
;
91 local $_
= $File
::Find
::name
;
92 my $f
= $_
; s|^\Q
%{buildroot}\E||
;
94 return $files
[@files
] = $_
if -f $f
;
97 /\Q$d\E
/ && return for reverse sort @INC
;
98 $d
=~
/\Q$_\E
/ && return
99 for qw|
/etc
%_prefix/man
%_prefix/bin
%_prefix/share|
;
106 $x
=~
/^\Q$_\E\
// && $x ne $_
&& return 1 for @
dirs;
110 [ -z
%filelist ] && {
111 echo "ERROR
: empty
%files listing"
116 [ "
%{buildroot}" != "/" ] && rm -rf %{buildroot}
119 %defattr(-,root
,root
)
122 * Fri Nov
24 2006 root@dca02