2 # - XML::Filter::XInclude -
3 # This spec file was automatically generated by cpan2rpm [ver: 2.027]
4 # The following arguments were used:
5 # --spec-only --version=1.0 '--author=Matt Sergeant' XML-Filter-XInclude-1.0.tar.gz
6 # For more information on cpan2rpm please visit: http://perl.arix.com/
9 %define pkgname XML
-Filter
-XInclude
10 %define filelist
%{pkgname}-%{version}-filelist
11 %define NVR
%{pkgname}-%{version}-%{release}
14 name
: perl
-XML
-Filter
-XInclude
15 summary
: XML
-Filter
-XInclude
- XInclude as a SAX Filter
19 packager
: Arix International
<cpan2rpm@arix.com
>
21 group
: Applications
/CPAN
22 url
: http
://www.cpan.org
23 buildroot
: %{_tmppath}/%{name}-%{version}-%
(id
-u
-n
)
25 prefix
: %
(echo %{_prefix})
26 source: XML
-Filter
-XInclude
-1.0.tar.gz
29 This module implements a simple SAX filter that provides XInclude
30 support. It does
*NOT
* support XPointer.
32 XInclude is very simple
, just include something like this
in
35 <xi
:include href
="foo.xml"
36 xmlns
:xi
="http
://www.w3.org
/2001/XInclude"
/>
38 And it will load foo.xml and parse it
in the current SAX stream.
40 If you specify the attribute parse
="text"
, it will be treated as
41 a plain text file
, and inserted into the stream as a series of calls
42 to the characters
() method.
44 URI's are supported via LWP.
46 Currently encoding is not supported.
49 # This package was generated automatically with the cpan2rpm
50 # utility. To get this software or for more information
51 # please visit: http://perl.arix.com/
55 %setup -q
-n
%{pkgname}-%{version}
56 chmod
-R u
+w
%{_builddir}/%{pkgname}-%{version}
59 grep
-rsl '^
#!.*perl' . |
60 grep
-v '.bak$' |xargs
--no
-run
-if-empty \
61 %__perl -MExtUtils
::MakeMaker
-e 'MY
->fixin
(@ARGV
)'
62 CFLAGS
="$RPM_OPT_FLAGS"
63 %{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}|
if \$ExtUtils
::MakeMaker
::VERSION
=~
/5\
.9[1-6]|
6\
.0[0-5]/ '`
70 [ "
%{buildroot}" != "/" ] && rm -rf %{buildroot}
72 %{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '`
74 cmd
=/usr
/share
/spec
-helper
/compress_files
75 [ -x $cmd
] || cmd
=/usr
/lib
/rpm
/brp
-compress
79 if [ -e
/etc
/SuSE
-release
-o
-e
/etc
/UnitedLinux
-release
]
81 %{__mkdir_p} %{buildroot}/var
/adm
/perl
-modules
82 %{__cat} `find %{buildroot} -name "perllocal.pod"` \
83 |
%{__sed} -e s+%{buildroot}++g \
84 > %{buildroot}/var/adm/perl-modules/%{name}
87 # remove special files
88 find
%{buildroot} -name "perllocal.pod" \
89 -o
-name ".packlist" \
93 # no empty directories
94 find
%{buildroot}%{_prefix} \
96 -exec rmdir {} \
; 2>/dev
/null
98 %{__perl} -MFile
::Find
-le '
99 find
({ wanted
=> \
&wanted
, no_chdir
=> 1}, "
%{buildroot}"
);
100 print "
%doc Changes examples README"
;
101 for my $x
(sort @
dirs, @files
) {
102 push @ret
, $x unless indirs
($x
);
104 print join "\n"
, sort @ret
;
109 local $_
= $File
::Find
::name
;
110 my $f
= $_
; s|^\Q
%{buildroot}\E||
;
111 return unless length
;
112 return $files
[@files
] = $_
if -f $f
;
115 /\Q$d\E
/ && return for reverse sort @INC
;
116 $d
=~
/\Q$_\E
/ && return
117 for qw|
/etc
%_prefix/man
%_prefix/bin
%_prefix/share|
;
124 $x
=~
/^\Q$_\E\
// && $x ne $_
&& return 1 for @
dirs;
128 [ -z
%filelist ] && {
129 echo "ERROR
: empty
%files listing"
134 [ "
%{buildroot}" != "/" ] && rm -rf %{buildroot}
137 %defattr(-,root
,root
)
140 * Fri Nov
24 2006 root@dca02