3 # This spec file was automatically generated by cpan2rpm [ver: 2.027]
4 # The following arguments were used:
5 # --spec-only --version=1.13 '--author=Matt Sergeant' DBD-SQLite-1.13.tar.gz
6 # For more information on cpan2rpm please visit: http://perl.arix.com/
9 %define pkgname DBD
-SQLite
10 %define filelist
%{pkgname}-%{version}-filelist
11 %define NVR
%{pkgname}-%{version}-%{release}
15 summary
: DBD
-SQLite
- Self Contained RDBMS
in a DBI Driver
19 packager
: Arix International
<cpan2rpm@arix.com
>
21 group
: Applications
/CPAN
22 url
: http
://www.cpan.org
23 buildroot
: %{_tmppath}/%{name}-%{version}-%
(id
-u
-n
)
24 prefix
: %
(echo %{_prefix})
25 source: DBD
-SQLite
-1.13.tar.gz
28 SQLite is a public domain RDBMS database engine that you can find
29 at http
://www.hwaci.com
/sw
/sqlite
/.
31 Rather than ask you to
install SQLite first
, because SQLite is public
32 domain
, DBD
::SQLite includes the entire thing
in the distribution. So
33 in order to get a fast transaction capable RDBMS working
for your
34 perl project you simply have to
install this module
, and nothing
37 SQLite supports the following features
:
41 =item Implements a large subset of SQL92
43 See http
://www.hwaci.com
/sw
/sqlite
/lang.html
for details.
45 =item A complete DB
in a single disk file
47 Everything
for your database is stored
in a single disk file
, making it
48 easier to move things around than with DBD
::CSV.
50 =item Atomic commit and rollback
52 Yes
, DBD
::SQLite is small and light
, but it supports full transactions
!
56 User
-defined aggregate or regular functions can be registered with the
61 There's lots more to it
, so please refer to the docs on the SQLite web
62 page
, listed above
, for SQL details. Also refer to DBI
for details
63 on how to use DBI itself.
66 # This package was generated automatically with the cpan2rpm
67 # utility. To get this software or for more information
68 # please visit: http://perl.arix.com/
72 %setup -q
-n
%{pkgname}-%{version}
73 chmod
-R u
+w
%{_builddir}/%{pkgname}-%{version}
76 grep
-rsl '^
#!.*perl' . |
77 grep
-v '.bak$' |xargs
--no
-run
-if-empty \
78 %__perl -MExtUtils
::MakeMaker
-e 'MY
->fixin
(@ARGV
)'
79 CFLAGS
="$RPM_OPT_FLAGS"
80 %{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}|
if \$ExtUtils
::MakeMaker
::VERSION
=~
/5\
.9[1-6]|
6\
.0[0-5]/ '`
87 [ "
%{buildroot}" != "/" ] && rm -rf %{buildroot}
89 %{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '`
91 cmd
=/usr
/share
/spec
-helper
/compress_files
92 [ -x $cmd
] || cmd
=/usr
/lib
/rpm
/brp
-compress
96 if [ -e
/etc
/SuSE
-release
-o
-e
/etc
/UnitedLinux
-release
]
98 %{__mkdir_p} %{buildroot}/var
/adm
/perl
-modules
99 %{__cat} `find %{buildroot} -name "perllocal.pod"` \
100 |
%{__sed} -e s+%{buildroot}++g \
101 > %{buildroot}/var/adm/perl-modules/%{name}
104 # remove special files
105 find
%{buildroot} -name "perllocal.pod" \
106 -o
-name ".packlist" \
110 # no empty directories
111 find
%{buildroot}%{_prefix} \
113 -exec rmdir {} \
; 2>/dev
/null
115 %{__perl} -MFile
::Find
-le '
116 find
({ wanted
=> \
&wanted
, no_chdir
=> 1}, "
%{buildroot}"
);
117 print "
%doc Changes README"
;
118 for my $x
(sort @
dirs, @files
) {
119 push @ret
, $x unless indirs
($x
);
121 print join "\n"
, sort @ret
;
126 local $_
= $File
::Find
::name
;
127 my $f
= $_
; s|^\Q
%{buildroot}\E||
;
128 return unless length
;
129 return $files
[@files
] = $_
if -f $f
;
132 /\Q$d\E
/ && return for reverse sort @INC
;
133 $d
=~
/\Q$_\E
/ && return
134 for qw|
/etc
%_prefix/man
%_prefix/bin
%_prefix/share|
;
141 $x
=~
/^\Q$_\E\
// && $x ne $_
&& return 1 for @
dirs;
145 [ -z
%filelist ] && {
146 echo "ERROR
: empty
%files listing"
151 [ "
%{buildroot}" != "/" ] && rm -rf %{buildroot}
154 %defattr(-,root
,root
)
157 * Mon Nov
27 2006 root@dca02