2 # - Mail::RFC822::Address -
3 # This spec file was automatically generated by cpan2rpm [ver: 2.027]
4 # The following arguments were used:
5 # --spec-only --version=0.3 '--author=Paul Warren' Mail-RFC822-Address-0.3.tar.gz
6 # For more information on cpan2rpm please visit: http://perl.arix.com/
9 %define pkgname Mail
-RFC822
-Address
10 %define filelist
%{pkgname}-%{version}-filelist
11 %define NVR
%{pkgname}-%{version}-%{release}
14 name
: perl
-Mail
-RFC822
-Address
15 summary
: Mail
-RFC822
-Address
- Perl extension
for validating email addresses
19 packager
: Arix International
<cpan2rpm@arix.com
>
21 group
: Applications
/CPAN
22 url
: http
://www.cpan.org
23 buildroot
: %{_tmppath}/%{name}-%{version}-%
(id
-u
-n
)
25 prefix
: %
(echo %{_prefix})
26 source: Mail
-RFC822
-Address
-0.3.tar.gz
29 Mail
::RFC822
::Address validates email addresses against the grammar described
30 in RFC
822 using regular expressions. How to validate a user supplied email
31 address is a FAQ
(see perlfaq9
): the only sure way to see
if a supplied email
32 address is genuine is to send an email to it and see
if the user recieves it.
33 The one useful check that can be performed on an address is to check that the
34 email address is syntactically valid. That is what this module does.
36 This module is functionally equivalent to RFC
::RFC822
::Address
, but uses
37 regular expressions rather than the Parse
::RecDescent parser. This means that
38 startup
time is greatly reduced making it suitable
for use
in transient scripts
42 # This package was generated automatically with the cpan2rpm
43 # utility. To get this software or for more information
44 # please visit: http://perl.arix.com/
48 %setup -q
-n
%{pkgname}-%{version}
49 chmod
-R u
+w
%{_builddir}/%{pkgname}-%{version}
52 grep
-rsl '^
#!.*perl' . |
53 grep
-v '.bak$' |xargs
--no
-run
-if-empty \
54 %__perl -MExtUtils
::MakeMaker
-e 'MY
->fixin
(@ARGV
)'
55 CFLAGS
="$RPM_OPT_FLAGS"
56 %{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}|
if \$ExtUtils
::MakeMaker
::VERSION
=~
/5\
.9[1-6]|
6\
.0[0-5]/ '`
63 [ "
%{buildroot}" != "/" ] && rm -rf %{buildroot}
65 %{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '`
67 cmd
=/usr
/share
/spec
-helper
/compress_files
68 [ -x $cmd
] || cmd
=/usr
/lib
/rpm
/brp
-compress
72 if [ -e
/etc
/SuSE
-release
-o
-e
/etc
/UnitedLinux
-release
]
74 %{__mkdir_p} %{buildroot}/var
/adm
/perl
-modules
75 %{__cat} `find %{buildroot} -name "perllocal.pod"` \
76 |
%{__sed} -e s+%{buildroot}++g \
77 > %{buildroot}/var/adm/perl-modules/%{name}
80 # remove special files
81 find
%{buildroot} -name "perllocal.pod" \
82 -o
-name ".packlist" \
86 # no empty directories
87 find
%{buildroot}%{_prefix} \
89 -exec rmdir {} \
; 2>/dev
/null
91 %{__perl} -MFile
::Find
-le '
92 find
({ wanted
=> \
&wanted
, no_chdir
=> 1}, "
%{buildroot}"
);
93 print "
%doc Changes INSTALL"
;
94 for my $x
(sort @
dirs, @files
) {
95 push @ret
, $x unless indirs
($x
);
97 print join "\n"
, sort @ret
;
102 local $_
= $File
::Find
::name
;
103 my $f
= $_
; s|^\Q
%{buildroot}\E||
;
104 return unless length
;
105 return $files
[@files
] = $_
if -f $f
;
108 /\Q$d\E
/ && return for reverse sort @INC
;
109 $d
=~
/\Q$_\E
/ && return
110 for qw|
/etc
%_prefix/man
%_prefix/bin
%_prefix/share|
;
117 $x
=~
/^\Q$_\E\
// && $x ne $_
&& return 1 for @
dirs;
121 [ -z
%filelist ] && {
122 echo "ERROR
: empty
%files listing"
127 [ "
%{buildroot}" != "/" ] && rm -rf %{buildroot}
130 %defattr(-,root
,root
)
133 * Thu Nov
23 2006 root@dca02