current version
[opsoft_test.git] / silentbob / debian / rules
blob0004d86adaf6a7c4b75f2e7cc3d8d6c087a7e5a4
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
13 # These are used for cross-compiling and for saving the configure script
14 # from having to guess our platform (since we know it already)
15 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
16 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
19 CFLAGS = -Wall -g
21 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
22 CFLAGS += -O0
23 else
24 CFLAGS += -O2
25 endif
27 config.status: configure
28 dh_testdir
29 # Add here commands to configure the package.
30 ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info CFLAGS="$(CFLAGS)" LDFLAGS="-Wl,-z,defs"
33 build: build-stamp
35 build-stamp: config.status
36 dh_testdir
38 # Add here commands to compile the package.
39 $(MAKE)
40 #docbook-to-man debian/silentbob.sgml > silentbob.1
42 touch $@
44 clean:
45 dh_testdir
46 dh_testroot
47 rm -f build-stamp
49 # Add here commands to clean up after the build process.
50 -$(MAKE) distclean
51 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
52 cp -f /usr/share/misc/config.sub config.sub
53 endif
54 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
55 cp -f /usr/share/misc/config.guess config.guess
56 endif
59 dh_clean
61 install: build
62 dh_testdir
63 dh_testroot
64 dh_clean -k
65 dh_installdirs
67 # Add here commands to install the package into debian/silentbob.
68 $(MAKE) install DESTDIR=$(CURDIR)/debian/silentbob
69 rm -f plugins/.lib/*.so.*
70 mkdir -p $(CURDIR)/debian/silentbob/usr/lib/silent_bob/
71 cp $(CURDIR)/plugins/.libs/*.so.0.0.0 $(CURDIR)/debian/silentbob/usr/lib/silent_bob/
73 # Build architecture-independent files here.
74 binary-indep: build install
75 # We have nothing to do by default.
77 # Build architecture-dependent files here.
78 binary-arch: build install
79 dh_testdir
80 dh_testroot
81 dh_installchangelogs ChangeLog
82 dh_installdocs
83 dh_installexamples
84 # dh_install
85 # dh_installmenu
86 # dh_installdebconf
87 # dh_installlogrotate
88 # dh_installemacsen
89 # dh_installpam
90 # dh_installmime
91 # dh_python
92 # dh_installinit
93 # dh_installcron
94 # dh_installinfo
95 dh_installman
96 dh_link `cat debian/package.links`
97 dh_strip
98 dh_compress
99 dh_fixperms
100 # dh_perl
101 # dh_makeshlibs
102 dh_installdeb
103 dh_shlibdeps
104 dh_gencontrol
105 dh_md5sums
106 dh_builddeb
108 binary: binary-indep binary-arch
109 .PHONY: build clean binary-indep binary-arch binary install