3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
13 # These are used for cross-compiling and for saving the configure script
14 # from having to guess our platform (since we know it already)
15 DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
16 DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
21 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
27 config.status
: configure
29 # Add here commands to configure the package.
30 .
/configure
--host
=$(DEB_HOST_GNU_TYPE
) --build
=$(DEB_BUILD_GNU_TYPE
) --prefix=/usr
--mandir=\
$${prefix}/share
/man
--infodir=\
$${prefix}/share
/info CFLAGS
="$(CFLAGS)" LDFLAGS
="-Wl,-z,defs"
35 build-stamp
: config.status
38 # Add here commands to compile the package.
40 #docbook-to-man debian/silentbob.sgml > silentbob.1
49 # Add here commands to clean up after the build process.
51 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
52 cp
-f
/usr
/share
/misc
/config.sub config.sub
54 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
55 cp
-f
/usr
/share
/misc
/config.guess config.guess
67 # Add here commands to install the package into debian/silentbob.
68 $(MAKE
) install DESTDIR
=$(CURDIR
)/debian
/silentbob
69 rm -f plugins
/.lib
/*.so.
*
70 mkdir
-p
$(CURDIR
)/debian
/silentbob
/usr
/lib
/silent_bob
/
71 cp
$(CURDIR
)/plugins
/.libs
/*.so
.0.0.0 $(CURDIR
)/debian
/silentbob
/usr
/lib
/silent_bob
/
73 # Build architecture-independent files here.
74 binary-indep
: build
install
75 # We have nothing to do by default.
77 # Build architecture-dependent files here.
78 binary-arch
: build
install
81 dh_installchangelogs ChangeLog
96 dh_link
`cat debian/package.links`
108 binary
: binary-indep binary-arch
109 .PHONY
: build
clean binary-indep binary-arch binary
install