1 DESCRIPTION
= "Alsa sound library"
2 HOMEPAGE
= "http://www.alsa-project.org"
3 SECTION
= "libs/multimedia"
8 # configure.in sets
-D__arm__ on the command
line for any arm system
9 #
(not just those with the ARM instruction set
), this should be removed
,
10 #
(or replaced by a permitted #define
).
11 #FIXME
: remove the following
12 ARM_INSTRUCTION_SET
= "arm"
14 SRC_URI
= "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-${PV}.tar.bz2 \
15 file://fix-tstamp-declaration.patch;patch=1 \
16 file://unbreak_plugindir.patch;patch=1"
18 inherit autotools pkgconfig
21 EXTRA_OECONF
+= "${@get_alsa_fpu_setting(bb, d)} "
23 EXTRA_OECONF
= "--with-cards=pdaudiocf --with-oss=yes"
26 oe_libinstall
-so
-C src libasound $
{STAGING_LIBDIR
}/
27 install
-d $
{STAGING_INCDIR
}/alsa
/sound
28 install
-m
0644 include/*.h $
{STAGING_INCDIR
}/alsa
/
29 install
-m
0644 include/sound
/ainstr
*.h $
{STAGING_INCDIR
}/alsa
/sound
/
30 install
-d $
{STAGING_DATADIR
}/aclocal
31 install
-m
0644 utils
/alsa.m4 $
{STAGING_DATADIR
}/aclocal
/
34 PACKAGES
=+ "alsa-server libasound alsa-conf-base alsa-conf alsa-doc alsa-dev"
35 FILES_$
{PN
}-dbg
+= "${libdir}/alsa-lib/*/.debu*"
36 FILES_libasound
= "${libdir}/libasound.so.*"
37 FILES_alsa
-server
= "${bindir}/*"
38 FILES_alsa
-conf
= "${datadir}/alsa/"
39 FILES_alsa
-dev
+= "${libdir}/pkgconfig/ /usr/include/ ${datadir}/aclocal/*"
40 FILES_alsa
-conf
-base
= "\
41 ${datadir}/alsa/alsa.conf \
42 ${datadir}/alsa/cards/aliases.conf \
43 ${datadir}/alsa/pcm/default.conf \
44 ${datadir}/alsa/pcm/dmix.conf \
45 ${datadir}/alsa/pcm/dsnoop.conf"
47 RDEPENDS_libasound
= "alsa-conf-base"