merge of '07a342693675fe2b1daacf0eb62302579d9fade3'
[org.openembedded.dev.git] / packages / alsa / alsa-utils_1.0.14.bb
blob25eeade7cd156ebf7a99a07b19f60d84fc803d73
1 DESCRIPTION = "ALSA Utilities"
2 HOMEPAGE = "http://www.alsa-project.org"
3 SECTION = "console/utils"
4 LICENSE = "GPL"
5 DEPENDS = "alsa-lib ncurses"
6 PR = "r1"
8 SRC_URI = "ftp://ftp.alsa-project.org/pub/utils/alsa-utils-${PV}.tar.bz2 \
9 file://alsa-utils-automake.patch;patch=1 \
11 inherit autotools
13 # This are all packages that we need to make. Also, the now empty alsa-utils
14 # ipk depend on them.
16 PACKAGES += "\
17 alsa-utils-alsamixer \
18 alsa-utils-midi \
19 alsa-utils-aplay \
20 alsa-utils-amixer \
21 alsa-utils-aconnect \
22 alsa-utils-iecset \
23 alsa-utils-speakertest \
24 alsa-utils-aseqnet \
25 alsa-utils-aseqdump \
26 alsa-utils-alsaconf \
27 alsa-utils-alsactl "
29 # We omit alsaconf, because
30 # a) this is a bash script
31 # b) it creates config files not suitable for OE-based distros
33 FILES_${PN} = ""
34 FILES_alsa-utils-aplay = "${bindir}/aplay ${bindir}/arecord"
35 FILES_alsa-utils-amixer = "${bindir}/amixer"
36 FILES_alsa-utils-alsamixer = "${bindir}/alsamixer"
37 FILES_alsa-utils-speakertest = "${bindir}/speaker-test ${datadir}/sounds/alsa/ ${datadir}/alsa/"
38 FILES_alsa-utils-midi = "${bindir}/aplaymidi ${bindir}/arecordmidi ${bindir}/amidi"
39 FILES_alsa-utils-aconnect = "${bindir}/aconnect"
40 FILES_alsa-utils-aseqnet = "${bindir}/aseqnet"
41 FILES_alsa-utils-iecset = "${bindir}/iecset"
42 FILES_alsa-utils-alsactl = "${sbindir}/alsactl"
43 FILES_alsa-utils-aseqdump = "${bindir}/aseqdump"
44 FILES_alsa-utils-alsaconf = "${sbindir}/alsaconf"
46 DESCRIPTION_alsa-utils-aplay = "play (and record) sound files via ALSA"
47 DESCRIPTION_alsa-utils-amixer = "command-line based control for ALSA mixer and settings"
48 DESCRIPTION_alsa-utils-alsamixer = "ncurses based control for ALSA mixer and settings"
49 DESCRIPTION_alsa-utils-speakertest = "ALSA surround speaker test utility"
50 DESCRIPTION_alsa-utils-midi = "miscalleanous MIDI utilities for ALSA"
51 DESCRIPTION_alsa-utils-aconnect = "ALSA sequencer connection manager"
52 DESCRIPTION_alsa-utils-aseqnet = "network client/server on ALSA sequencer"
53 DESCRIPTION_alsa-utils-alsactl = "saves/restores ALSA-settings in /etc/asound.state"
54 DESCRIPTION_alsa-utils-alsaconf = "a bash script that creates ALSA configuration files"
56 ALLOW_EMPTY_alsa-utils = "1"