merge of '07a342693675fe2b1daacf0eb62302579d9fade3'
[org.openembedded.dev.git] / packages / automake / automake_1.8.2.bb
blob30002191f57f327cfb64e050032292c38f1f0d07
1 SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.bz2 \
2 file://automake182-update-configscripts.patch;patch=1;pnum=1 \
3 ${@['file://path_prog_fixes.patch;patch=1', ''][bb.data.inherits_class('native', d)]}"
4 DESCRIPTION = "A tool for automatically generating Makefiles."
5 SECTION = "devel"
6 LICENSE = "GPL"
7 PR = "r7"
9 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/automake-${PV}"
11 inherit autotools
13 FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
15 require automake.inc
17 do_install () {
18 oe_runmake 'DESTDIR=${D}' install
19 install -d ${D}${datadir}
20 if [ ! -e ${D}${datadir}/aclocal ]; then
21 ln -sf aclocal-1.8 ${D}${datadir}/aclocal
23 if [ ! -e ${D}${datadir}/automake ]; then
24 ln -sf automake-1.8 ${D}${datadir}/automake