1 require cacao
-native.inc
3 PROVIDES
= "virtual/java-initial"
5 DEPENDS
= "zlib-native libtool-native fastjar-native classpath-initial jikes-initial"
10 http://www.complang.tuwien.ac.at/cacaojvm/download/cacao-${PV}/cacao-${PV}.tar.bz2; \
11 file://cacao-0.98-initial.patch;patch=1;pnum=1 \
14 # libjvm disabled
- it would conflict with cacao
-native installations
17 --with-classpath-libdir=${libdir} \
18 --with-classpath-includedir=${includedir}/classpath-initial \
19 --with-classpath-classes=${datadir}/classpath-initial/glibj.zip \
20 --with-vm-zip=${datadir}/cacao-initial/vm.zip \
21 --program-suffix=-initial \
25 # enforces the usage of jikes
-initial
26 export JAVAC
=jikes
-initial
28 # enforces the usage of fastjar
31 do_configure_append
() {
32 # Fix the executable name in the wrapper script.
33 sed
-i
-e
"s|exec cacao|exec cacao-initial|" src
/scripts
/java.in