merge of '07a342693675fe2b1daacf0eb62302579d9fade3'
[org.openembedded.dev.git] / packages / cups / cups_1.1.23.bb
blobb17d899a3d4ac146f4d8d567d12acd3b3777e8a3
1 DESCRIPTION = "An Internet printing system for Unix."
2 SECTION = "console/utils"
3 LICENSE = "GPL LGPL"
4 DEPENDS = "openssl jpeg libpng zlib install-native fakeroot-native"
5 PR = "r6"
7 SRC_URI = "ftp://ftp3.easysw.com/pub/cups/${PV}/cups-${PV}-source.tar.bz2 \
8 file://strftime_fix.patch;patch=1"
10 inherit autotools binconfig
12 LDFLAGS += " -L${STAGING_LIBDIR} "
14 do_compile () {
15 #Eeeks! Hack alert!
16 grep CUPS config.h.in~ | grep define >> config.h
17 sed -i s:STRIP:NOSTRIP: Makedefs
18 sed -i s:serial:: backend/Makefile
20 oe_runmake "SSLLIBS=-lssl -lcrypto -L${STAGING_LIBDIR}" \
21 "LIBPNG=-lpng -lm -L${STAGING_LIBDIR}" \
22 "LIBJPEG=-ljpeg -L${STAGING_LIBDIR}" \
23 "LIBZ=-lz -L${STAGING_LIBDIR}" \
24 "-I."
27 fakeroot do_install () {
28 oe_runmake "DSTROOT=${D}" install
31 do_stage () {
32 install -d ${STAGING_INCDIR}/cups
33 install ${S}/cups/*.h ${STAGING_INCDIR}/cups/
34 install ${S}/filter/*.h ${STAGING_INCDIR}/cups/
35 oe_libinstall -C cups -so libcups ${STAGING_LIBDIR}
36 oe_libinstall -C filter -so libcupsimage ${STAGING_LIBDIR}
39 #package the html for the webgui inside the main packages (~1MB uncompressed)
40 FILES_${PN} += "${datadir}/doc/cups/images \
41 ${datadir}/doc/cups/*html \
42 ${datadir}/doc/cups/*.css \