merge of '07a342693675fe2b1daacf0eb62302579d9fade3'
[org.openembedded.dev.git] / packages / dhcp-forwarder / dhcp-forwarder_0.7.bb
blob8cf060e28786b956c68e47f396ab75c12725a3e1
1 SECTION = "console/network"
2 DESCRIPTION = "This program is used to forward DHCP and BOOTP messages between two \
3 networks with different broadcast domains. \
4 It works better with ppp - and especially with ipsec over ppp - than \
5 dhcp-relay from ISC and has a smaller foot print."
6 HOMEPAGE = "http://www.nongnu.org/dhcp-fwd/"
7 LICENSE = "GPLv2"
9 SRC_URI = "http://savannah.nongnu.org/download/dhcp-fwd/dhcp-forwarder-${PV}.tar.bz2 \
10 file://init \
11 file://dhcp-fwd.cfg"
13 inherit autotools update-rc.d
15 EXTRA_OECONF="--disable-dietlibc"
17 INITSCRIPT_NAME="dhcp-forwarder"
18 INITSCRIPT_PARAMS="defaults"
20 do_install_append() {
21 install -d ${D}${sysconfdir}/init.d
22 install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/dhcp-forwarder
23 install -m 0644 ${WORKDIR}/dhcp-fwd.cfg ${D}${sysconfdir}
26 CONFFILES_${PN}_nylon = "${sysconfdir}/dhcp-fwd.cfg"