merge of '07a342693675fe2b1daacf0eb62302579d9fade3'
[org.openembedded.dev.git] / packages / fakeroot / fakeroot-native_1.7.1.bb
blob8b3d2a159040e179bd7a5404ce825f3e1fb621ad
1 SECTION = "base"
2 require fakeroot_${PV}.bb
3 inherit native
4 RDEPENDS="util-linux-native"
6 SRC_URI += "file://fix-prefix.patch;patch=1 "
7 S = "${WORKDIR}/fakeroot-${PV}"
9 EXTRA_OECONF = " --program-prefix="
11 # Compatability for the rare systems not using or having SYSV
12 python () {
13 if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
14 bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
17 do_stage_append () {
18 oe_libinstall -so libfakeroot ${STAGING_LIBDIR}/libfakeroot/