merge of '07a342693675fe2b1daacf0eb62302579d9fade3'
[org.openembedded.dev.git] / packages / ixp4xx / ixp4xx-csr_1.4.bb
blob3e5b444002b410b89124e659190d8229d39d5329
1 # Intel ixp4xx access library software. Note that this has an Intel
2 # license which restricts its use.
3 HOMEPAGE = "http://www.intel.com/design/network/products/npfamily/ixp420.htm"
4 LICENSE = "http://www.intel.com/design/network/swsup/np_sla/ixp400.htm"
5 LICENSE_HOMEPAGE = "http://www.intel.com/design/network/products/npfamily/ixp425swr1.htm"
6 # You must download the following software to your OpenEmbedded downloads
7 # directory before using this package:
9 # ixp400AccessLibrary-1_4.zip
11 # To do this go to the LICENSE_HOMEPAGE above, register/login (using a
12 # web browser which is supported by the login page), this will give you
13 # access to the web page from which you can download the software - you
14 # need the: "IntelĀ® IXP400 Software and RedBoot* Boot Loader", follow
15 # the "Archived" link and the v1.4 software then select the the "Intel
16 # Hardware Access Software" "1.4 download", this will take you to the
17 # license agreement which you must accept to use this package.
19 # Store the file with the name given below in your downloads directory
21 SRC_URI = "http://www.intel.com/Please-Read-The-BB-File/ixp400AccessLibrary-1_4.zip"
22 SRC_URI += "http://www.wnk.at/ixp400_accesslib_kernel26/data/patch_accesslib_kernel26_20040811.diff;patch=1"
23 SRC_URI += "file://badpaths.patch;patch=1"
24 SRC_URI += "file://build-timing-annoyance.patch;patch=1"
26 S = "${WORKDIR}/ixp400_xscale_sw"
27 PR = "r6"
29 COMPATIBLE_HOST = "^armeb-linux.*"
30 COMPATIBLE_MACHINE = "(nslu2|ixp4xx)"
32 inherit module
34 #LINUX_MACH_CFLAGS := -D__LINUX_ARM_ARCH__=5 -mcpu=xscale -mtune=xscale
35 CFLAGS = "-fno-common -D__KERNEL__ -DMODULE -D__linux -DCPU=33 -DXSCALE=33 \
36 -D__LINUX_ARM_ARCH__=5 \
37 -I${S}/src/linux -I${S}/src/include \
38 ${BUILD_OPTIMIZATION} \
39 -I${STAGING_KERNEL_DIR}/include"
41 EXTRA_OEMAKE = "'CFLAGS=${CFLAGS}' \
42 'CC=${KERNEL_CC}' \
43 'LD=${KERNEL_LD}' \
44 'IX_TARGET=linuxbe' \
45 'LINUX_SRC=${STAGING_KERNEL_DIR}' \
46 'ARCH=${ARCH}'"
47 #EXTRA_OEMAKE = "'LINUX_SRC=${STAGING_KERNEL_DIR}' 'IX_TARGET=${IX_TARGET}' \
48 # 'ARCH=${TARGET_ARCH}' 'CROSS_COMPILE=${TARGET_PREFIX}'"
50 do_compile () {
51 oe_runmake ixp400.ko
54 do_stage () {
55 install -d ${STAGING_INCDIR}/linux/ixp4xx-csr
56 install -m 0644 src/include/*.h ${STAGING_INCDIR}/linux/ixp4xx-csr/
57 cp -RLf src/linux/* ${STAGING_INCDIR}/linux/ixp4xx-csr/
60 do_install () {
61 install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/drivers/ixp400
62 install -m 0644 lib/linuxbe/ixp400.ko ${D}${base_libdir}/modules/${KERNEL_VERSION}/drivers/ixp400/