2 DESCRIPTION
= "A cross platform audio library"
3 HOMEPAGE
= "http://www.xiph.org/ao/"
6 DEPENDS
= "alsa-lib pulseaudio"
7 PROVIDES
= "libao-alsa libao-alsa-plugin"
10 SRC_URI
= "http://downloads.xiph.org/releases/ao/libao-${PV}.tar.gz"
12 inherit autotools pkgconfig
14 EXTRA_OECONF
= "--disable-esd --disable-esdtest \
15 --disable-alsa --enable-alsa09 \
16 --disable-arts --disable-nas \
20 install
-d $
{STAGING_INCDIR
}/ao
21 install
-m
0644 $
{S
}/include/ao
/ao.h $
{S
}/include/ao
/os_types.h \
22 $
{S
}/include/ao
/plugin.h $
{STAGING_INCDIR
}/ao
/
24 oe_libinstall
-so
-C src libao $
{STAGING_LIBDIR
}
25 install
-d $
{STAGING_DATADIR
}/aclocal
26 install
-m
0644 ao.m4 $
{STAGING_DATADIR
}/aclocal
/
29 PACKAGES
=+ "${PN}-alsa ${PN}-alsa-dev ${PN}-pulse ${PN}-pulse-dev"
31 FILES_$
{PN
}-alsa
= "${libdir}/ao/plugins-2/libalsa*.so"
32 FILES_$
{PN
}-alsa
-dev
= "${libdir}/ao/plugins-2/libalsa*.la"
33 FILES_$
{PN
}-pulse
= "${libdir}/ao/plugins-2/libpulse*.so"
34 FILES_$
{PN
}-pulse
-dev
= "${libdir}/ao/plugins-2/libpulse*.la"
36 FILES_$
{PN
} += "${libdir}/ao/plugins-2/*.so"
37 FILES_$
{PN
}-dev
+= "${libdir}/ao/plugins-2/*.la"
38 FILES_$
{PN
}-dbg
+= "${libdir}/ao/plugins-2/.debug"