2 DESCRIPTION
= "This package contains the scripts necessary \
3 for hotplug Linux support, and lets you plug in new devices \
4 and use them immediately."
6 RPROVIDES_$
{PN
} = "hotplug"
7 RCONFLICTS_$
{PN
} = "hotplug"
8 RREPLACES_$
{PN
} = "hotplug"
11 SRC_URI
= "${KERNELORG_MIRROR}/pub/linux/utils/kernel/hotplug/hotplug-2004_03_29.tar.gz \
12 file://busybox.patch;patch=1 \
13 file://fix-net.agent \
14 file://update-usb.usermap \
15 file://logcheck-ignore \
16 file://sleeve.agent file://sleeve.rc file://mmc.agent \
18 S
= "${WORKDIR}/hotplug-2004_03_29"
20 INITSCRIPT_NAME
= "hotplug"
21 INITSCRIPT_PARAMS
= "start 40 S . stop 89 0 6 ."
29 oldmandir
:= "${mandir}"
30 oldsbindir
:= "${sbindir}"
33 FILES_hotplug_append
= " ${oldsbindir}"
34 FILES_hotplug
-doc_append
= " ${oldmandir}"
36 export DEBFIX
= "sed -e 's:sysconfig/usb:default/hotplug.usb:'"
38 install
-d $
{D
}$
{sysconfdir
}/logcheck
/ignore.d \
39 $
{D
}$
{oldmandir
} $
{D
}$
{oldsbindir
}
40 oe_runmake prefix
=$
{D
}$
{prefix
} exec_prefix
=$
{D
}$
{exec_prefix
} \
41 etcdir
=$
{D
}$
{sysconfdir
} sbindir
=$
{D
}$
{sbindir
} \
42 mandir
=$
{D
}$
{oldmandir
} install
43 sh $
{WORKDIR
}/fix
-net.agent $
{D
}
44 install
-m
0755 $
{WORKDIR
}/update
-usb.usermap $
{D
}$
{oldsbindir
}/
45 install
-m
0644 $
{WORKDIR
}/logcheck
-ignore $
{D
}$
{sysconfdir
}/logcheck
/ignore.d
/hotplug
46 install
-m
0755 $
{WORKDIR
}/sleeve.agent $
{D
}$
{sysconfdir
}/hotplug
/
47 install
-m
0755 $
{WORKDIR
}/sleeve.rc $
{D
}$
{sysconfdir
}/hotplug
/
48 install
-m
0755 $
{WORKDIR
}/mmc.agent $
{D
}$
{sysconfdir
}/hotplug
/
49 install
-m
0755 $
{WORKDIR
}/usbd.agent $
{D
}$
{sysconfdir
}/hotplug
/