merge of '07a342693675fe2b1daacf0eb62302579d9fade3'
[org.openembedded.dev.git] / packages / lyx / lyx_1.5.1.bb
blob32e3096dbe7ded9bc21bcb03599b38be24d75689
1 DESCRIPTION = "LyX is an advanced type setting processor - a frontend for LaTeX"
2 SECTION = "x11/office"
3 LICENSE = "GPL"
4 HOMEPAGE = "http://www.lyx.org"
5 DEPENDS = "boost qt4-x11-free"
6 RSUGGESTS = "tetex"
7 RDEPENDS = "python-shell python-textutils"
8 PR = "r0"
10 SRC_URI = "http://lyx.cybermirror.org/stable/lyx-${PV}.tar.bz2"
12 inherit qt4x11 autotools
14 EXTRA_OECONF = " --with-qt4-dir=${QTDIR} -enable-pch"
15 EXTRA_QMAKEVARS_POST = "DEFINES+=_LIBC"
16 PARALLEL_MAKE = ""
18 do_configure_prepend() {
19 echo "NOTE: touching missing files, please report to upstream"
20 touch lib/configure.ac lib/doc/LaTeXConfig.lyx lib/textclass.lst
23 export UIC="${OE_QMAKE_UIC}"
24 export MOC="${OE_QMAKE_MOC}"
25 export OE_QMAKE_LIBS_X11="-lX11 -lXext"