1 DESCRIPTION
= "LyX is an advanced type setting processor - a frontend for LaTeX"
4 HOMEPAGE
= "http://www.lyx.org"
5 DEPENDS
= "boost qt4-x11-free"
7 RDEPENDS
= "python-shell python-textutils"
10 SRC_URI
= "http://lyx.cybermirror.org/stable/lyx-${PV}.tar.bz2"
12 inherit qt4x11 autotools
14 EXTRA_OECONF
= " --with-qt4-dir=${QTDIR} -enable-pch"
15 EXTRA_QMAKEVARS_POST
= "DEFINES+=_LIBC"
18 do_configure_prepend
() {
19 echo
"NOTE: touching missing files, please report to upstream"
20 touch lib
/configure.ac lib
/doc
/LaTeXConfig.lyx lib
/textclass.lst
23 export UIC
="${OE_QMAKE_UIC}"
24 export MOC
="${OE_QMAKE_MOC}"
25 export OE_QMAKE_LIBS_X11
="-lX11 -lXext"