1 DESCRIPTION
= "This package contains a set of programs for loading, inserting, and \
2 removing kernel modules for Linux (versions 2.5.48 and above). It serves \
3 the same function that the modutils package serves for Linux 2.4."
8 PACKAGES
=+ "module-init-tools-insmod-static module-init-tools-depmod"
9 RDEPENDS_$
{PN
} += "module-init-tools-depmod"
11 FILES_module
-init
-tools
-depmod
= "${sbindir}/depmod.26"
12 FILES_module
-init
-tools
-insmod
-static
= "${sbindir}/insmod.static"
14 SRC_URI
= "${KERNELORG_MIRROR}/pub/linux/utils/kernel/module-init-tools/module-init-tools-${PV}.tar.bz2 \
15 file://ignore_arch_directory;patch=1 \
16 file://modutils_extension;patch=1 \
17 file://no_man_rebuild;patch=1 \
18 file://manpagesopt;patch=1 \
19 file://module-init-tools-remove-index.patch;patch=1 "
20 S
= "${WORKDIR}/module-init-tools-${PV}"
22 EXTRA_OECONF
= "--disable-manpages"
31 for f in
bin/lsmod sbin
/insmod sbin
/rmmod sbin
/modprobe sbin
/modinfo sbin
/depmod
; do
36 pkg_postinst_module
-init
-tools
() {
38 for f in sbin
/insmod sbin
/modprobe sbin
/rmmod sbin
/modinfo
; do
40 update
-alternatives
--install
/$f $bn
/$f
.26 60
42 update
-alternatives
--install
/bin/lsmod
bin-lsmod
/bin/lsmod
.26 60
43 update
-alternatives
--install
/sbin
/lsmod lsmod
/bin/lsmod
.26 60
46 pkg_prerm_module
-init
-tools
() {
48 for f in sbin
/insmod sbin
/modprobe sbin
/rmmod sbin
/modinfo
; do
50 update
-alternatives
--remove $bn
/$f
.26
52 update
-alternatives
--remove
bin-lsmod
/bin/lsmod
.26
53 update
-alternatives
--remove lsmod
/bin/lsmod
.26
56 pkg_postinst_module
-init
-tools
-depmod
() {
58 update
-alternatives
--install
/sbin
/depmod depmod
/sbin
/depmod
.26 60
61 pkg_prerm_module
-init
-tools
-depmod
() {
63 update
-alternatives
--remove depmod
/sbin
/depmod
.26