merge of '07a342693675fe2b1daacf0eb62302579d9fade3'
[org.openembedded.dev.git] / packages / rott / rott_1.0.bb
blobe1fc4e6a74ddc4ed77734389775f82dc2b2ac6a6
1 DESCRIPTION = "Rise of the Triad - an SDL based Doom clone - QtE based Palmtop Environments Edition"
2 HOMEPAGE = "http://www.icculus.org/root"
3 LICENSE = "GPL"
4 PR = "r2"
6 APPIMAGE = "${WORKDIR}/rott.jpg"
8 SRC_URI = "http://icculus.org/rott/releases/rott-${PV}.tar.gz \
9 file://gcc4.patch;patch=1;pnum=2 \
10 file://rott.jpg"
11 S = "${WORKDIR}/rott-${PV}/rott"
13 CFLAGS += "-DPLATFORM_UNIX"
14 EXTRA_OEMAKE = 'SDL_INC_DIR=${STAGING_INCDIR}/SDL CC="${CC}" EXTRALDFLAGS="${LDFLAGS}"'
16 inherit sdl
18 do_install() {
19 install -d ${D}${bindir}
20 install -m 0755 rott ${D}${bindir}