merge of '07a342693675fe2b1daacf0eb62302579d9fade3'
[org.openembedded.dev.git] / packages / sane / sane-backends_1.0.17.bb
blob4854f4d10c36e8f2939dd94e79c389474f77b52c
1 DESCRIPTION = "Scanner drivers for SANE"
2 DEPENDS = "gphoto2 jpeg libusb"
3 LICENSE = "LGPL"
5 PR = "r2"
7 SRC_URI = "ftp://ftp.sane-project.org/pub/sane/old-versions/sane-backends-${PV}/sane-backends-${PV}.tar.gz \
8 file://Makefile.in.patch;patch=1 \
9 file://saned.xinetd \
12 inherit autotools pkgconfig binconfig
14 EXTRA_OECONF = "--disable-translations"
16 do_install_append() {
17 install -d "${D}/${sysconfdir}/xinetd.d"
18 install -m 755 "${S}/tools/.libs/sane-find-scanner" "${D}/${bindir}"
19 install -m 644 "${WORKDIR}/saned.xinetd" "${D}/${sysconfdir}/xinetd.d/saned"
22 PACKAGES =+ "libsane libsane-dev saned sane-utils"
24 FILES_libsane = "${libdir}/sane/*.so.* ${libdir}/lib*.so.* /etc"
25 RRECOMMENDS_libsane = "saned sane-utils"
26 FILES_libsane-dev += "${libdir}/sane/*"
28 RRECOMMENDS_saned = "xinetd"
29 FILES_saned = "${sbindir}/saned"
31 FILES_sane-utils = "${bindir}/*"
32 FILES_${PN}-dbg += "${libdir}/sane/.debug"
35 CONFFILES_libsane = "${sysconfdir}/sane.d/abaton.conf ${sysconfdir}/sane.d/agfafocus.conf ${sysconfdir}/sane.d/apple.conf ${sysconfdir}/sane.d/artec.conf ${sysconfdir}/sane.d/avision.conf ${sysconfdir}/sane.d/bh.conf ${sysconfdir}/sane.d/canon.conf ${sysconfdir}/sane.d/canon630u.conf ${sysconfdir}/sane.d/coolscan.conf ${sysconfdir}/sane.d/coolscan2.conf ${sysconfdir}/sane.d/dc25.conf ${sysconfdir}/sane.d/dmc.conf ${sysconfdir}/sane.d/epson.conf ${sysconfdir}/sane.d/fujitsu.conf ${sysconfdir}/sane.d/gt68xx.conf ${sysconfdir}/sane.d/hp.conf ${sysconfdir}/sane.d/leo.conf ${sysconfdir}/sane.d/matsushita.conf ${sysconfdir}/sane.d/microtek.conf ${sysconfdir}/sane.d/microtek2.conf ${sysconfdir}/sane.d/mustek.conf ${sysconfdir}/sane.d/mustek_usb.conf ${sysconfdir}/sane.d/nec.conf ${sysconfdir}/sane.d/pie.conf ${sysconfdir}/sane.d/plustek.conf ${sysconfdir}/sane.d/plustek_pp.conf ${sysconfdir}/sane.d/ricoh.conf ${sysconfdir}/sane.d/s9036.conf ${sysconfdir}/sane.d/sceptre.conf ${sysconfdir}/sane.d/sharp.conf ${sysconfdir}/sane.d/sp15c.conf ${sysconfdir}/sane.d/st400.conf ${sysconfdir}/sane.d/tamarack.conf ${sysconfdir}/sane.d/test.conf ${sysconfdir}/sane.d/teco1.conf ${sysconfdir}/sane.d/teco2.conf ${sysconfdir}/sane.d/teco3.conf ${sysconfdir}/sane.d/umax.conf ${sysconfdir}/sane.d/umax_pp.conf ${sysconfdir}/sane.d/umax1220u.conf ${sysconfdir}/sane.d/artec_eplus48u.conf ${sysconfdir}/sane.d/ma1509.conf ${sysconfdir}/sane.d/ibm.conf ${sysconfdir}/sane.d/hp5400.conf ${sysconfdir}/sane.d/u12.conf ${sysconfdir}/sane.d/snapscan.conf ${sysconfdir}/sane.d/dc210.conf ${sysconfdir}/sane.d/dc240.conf ${sysconfdir}/sane.d/gphoto2.conf ${sysconfdir}/sane.d/qcam.conf ${sysconfdir}/sane.d/v4l.conf ${sysconfdir}/sane.d/net.conf ${sysconfdir}/sane.d/dll.conf ${sysconfdir}/sane.d/saned.conf"
37 do_stage() {
38 autotools_stage_all