1 DESCRIPTION
= "A simple and easy to use Linux kernel (2.4+) module which allows you to mount remote filesystems using plain shell (ssh/rsh) connection. \
2 It supports some nice features like number of different caches for access speedup, target system optimisations, etc."
3 SECTION
= "kernel/modules"
8 SRC_URI
= "${SOURCEFORGE_MIRROR}/shfs/shfs-${PV}.tar.gz"
9 S
= "${WORKDIR}/shfs-${PV}/shfs/Linux-2.4"
11 #FIXME depend S on kernel version
16 unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
17 oe_runmake KERNEL_SOURCES
=$
{STAGING_KERNEL_DIR
} KERNEL
=$
{KERNEL_VERSION
} \
18 CC
="${KERNEL_CC}" LD
="${KERNEL_LD}" LINKER
="${KERNEL_LD}" LDFLAGS
=-r
22 install
-m
0644 shfs_fs.h shfs.h $
{STAGING_INCDIR
}/
26 install
-d $
{D
}$
{base_libdir
}/modules
/$
{KERNEL_VERSION
}/kernel
/fs
/shfs
/
27 install
-m
0644 shfs.o $
{D
}$
{base_libdir
}/modules
/$
{KERNEL_VERSION
}/kernel
/fs
/shfs
/shfs.o