merge of '07a342693675fe2b1daacf0eb62302579d9fade3'
[org.openembedded.dev.git] / packages / vectoroids / vectoroids_1.1.0.bb
blobbc3883390af2f32258caef0d385ab01ebe89b609
1 DESCRIPTION = "Clone of the classic arcade game Asteroids - SDL edition."
2 SECTION = "opie/games"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 PR = "r2"
7 APPIMAGE = "data/images/icon.png"
8 APPNAME = "vectoroids-${PV}"
10 SRC_URI = "ftp://ftp.billsgames.com/unix/x/vectoroids/src/vectoroids-${PV}.tar.gz"
12 inherit qmake sdl
14 EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=${STAGING_INCDIR}/SDL CONFIG-=qt \
15 LIBS+=-lSDL \
16 LIBS+=-lSDL_mixer \
17 LIBS+=-lSDL_image \
18 LIBS+=-lpthread \
19 DEFINES+=DATA_PREFIX=\\"\"${datadir}/vectoroids/\\"\""
21 do_configure_prepend() {
22 qmake -project vectoroids.pro
25 do_install() {
26 install -d ${D}${bindir}
27 install -m 0755 ${APPNAME} ${D}${bindir}
28 install -d ${D}${datadir}/vectoroids/
29 cp -pPR data/* ${D}${datadir}/vectoroids/