1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
5 inherit eutils java-pkg-2 java-ant-2
9 DESCRIPTION
="Java-based editor for the OpenStreetMap project"
10 HOMEPAGE
="http://josm.openstreetmap.de/"
11 SRC_URI
="http://josm.fabian-fingerle.de/${MY_P}.tar.lzma"
15 KEYWORDS
="~amd64 ~x86"
17 DEPEND
=">=virtual/jdk-1.6"
18 RDEPEND
=">=virtual/jre-1.6"
25 JAVA_ANT_ENCODING
=UTF-8
30 java-pkg_newjar
"dist/${PN}-custom.jar" || die
"java-pkg_newjar failed"
31 java-pkg_dolauncher
"${PN}" --jar "${PN}.jar" || die
"java-pkg_dolauncher failed"
33 newicon
"images/logo.png" ${PN}.png || die
"doicon failed"
34 make_desktop_entry
"${PN}" "Java OpenStreetMap Editor" josm
"Application"