repo.or.cz
/
ouch.git
/
blob
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
log
|
graphiclog1
|
graphiclog2
|
commit
|
commitdiff
|
tree
|
refs
|
edit
|
fork
blame
|
history
|
raw
|
HEAD
completions: hint generator to expand to file paths
[ouch.git]
/
benchmarks
/
shell.nix
blob
f7f37ae2d37d1fb6af441ca5ccfd6ea34c7d6c28
1
{ pkgs ? import <nixpkgs> { } }:
2
3
with pkgs;
4
5
let
6
ouch = rustPlatform.buildRustPackage {
7
pname = "ouch";
8
inherit ((lib.importTOML ../Cargo.toml).package) version;
9
src = ../.;
10
cargoLock.lockFile = ../Cargo.lock;
11
};
12
in
13
14
mkShell {
15
packages = [
16
gnutar
17
hyperfine
18
ouch
19
unzip
20
zip
21
];
22
}