makepkg: remove VCS package support
[pacman-ng.git] / proto / PKGBUILD-split.proto
blobf873db60fc21f87691e8f46d3110e2e8a82fa336
1 # This is an example of a PKGBUILD for splitting packages. Use this as a
2 # start to creating your own, and remove these comments. For more information,
3 # see 'man PKGBUILD'. NOTE: Please fill out the license field for your package!
4 # If it is unknown, then please put 'unknown'.
6 # Maintainer: Your Name <youremail@domain.com>
7 pkgname=('pkg1' 'pkg2')
8 pkgbase=BASE
9 pkgver=VERSION
10 pkgrel=1
11 epoch=
12 pkgdesc=""
13 arch=()
14 url=""
15 license=('GPL')
16 groups=()
17 depends=()
18 makedepends=()
19 checkdepends=()
20 provides=()
21 conflicts=()
22 replaces=()
23 backup=()
24 options=()
25 install=
26 changelog=
27 source=($pkgbase-$pkgver.tar.gz)
28 noextract=()
29 md5sums=() #generate with 'makepkg -g'
31 build() {
32   cd "$srcdir/$pkgbase-$pkgver"
33   ./configure --prefix=/usr
34   make
37 check() {
38   cd "$srcdir/$pkgname-$pkgver"
39   make -k check
42 package_pkg1() {
43   # options and directives that can be overridden
44   pkgver=
45   pkgrel=
46   epoch=
47   pkgdesc=""
48   arch=()
49   url=""
50   license=()
51   groups=()
52   depends=()
53   optdepends=()
54   provides=()
55   conflicts=()
56   replaces=()
57   backup=()
58   options=()
59   install=
60   changelog=
62   cd "$srcdir/$pkgbase-$pkgver"
63   make DESTDIR="$pkgdir/" install-pkg1
66 package_pkg2() {
67   # options and directives overrides
68   pkgdesc=""
70   cd "$srcdir/$pkgbase-$pkgver"
71   make DESTDIR="$pkgdir/" install-pkg2