3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 CHANGELOG
= debian
/changelog
12 PYTHON
= /usr
/bin
/python2.5
13 SETUP
= ${PYTHON} setup.py
16 DESTDIR
= debian
/${DEBPACKAGE}
26 make data
/panucci.service
44 ${SETUP} install --no-compile
-O2
--root
='$(DESTDIR)' --prefix='$(PREFIX)' --install-lib
/opt
/panucci
/lib
45 mv
$(DESTDIR
)/$(PREFIX
)/share
/panucci
/* $(DESTDIR
)/opt
/panucci
/
46 rm -rf
$(DESTDIR
)/$(PREFIX
)/share
/panucci
47 mkdir
-p
$(DESTDIR
)/$(PREFIX
)/share
/applications
/hildon
48 mv
$(DESTDIR
)/$(PREFIX
)/share
/applications
/*.desktop
$(DESTDIR
)/$(PREFIX
)/share
/applications
/hildon
52 binary-indep
: build
install
55 dh_installchangelogs
$(CHANGELOG
)
56 dh_installdocs
$(DOCS
)
68 .PHONY
: build
clean binary-indep binary-arch binary
install configure