fixed issue with calculating button width
[panucci.git] / debian / rules
blobf4943fd96ba06429eb8b92466e866e1236de42bc
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 CHANGELOG = debian/changelog
10 DOCS =
12 PYTHON = /usr/bin/python2.5
13 SETUP = ${PYTHON} setup.py
15 DEBPACKAGE = panucci
16 DESTDIR = debian/${DEBPACKAGE}
17 PREFIX = usr
19 configure:
20 true
22 build: build-stamp
23 build-stamp:
24 dh_testdir
25 make mo
26 make data/panucci.service
27 ${SETUP} build
28 touch build-stamp
30 clean:
31 dh_testdir
32 dh_testroot
33 rm -f build-stamp
34 ${SETUP} clean --all
35 rm -rf build dist
36 dh_clean
37 make clean
39 install: build
40 dh_testdir
41 dh_testroot
42 dh_clean -k
43 dh_installdirs
44 ${SETUP} install --no-compile -O2 --root='$(DESTDIR)' --prefix='$(PREFIX)' --install-lib /opt/panucci/lib
45 mv $(DESTDIR)/$(PREFIX)/share/panucci/* $(DESTDIR)/opt/panucci/
46 rm -rf $(DESTDIR)/$(PREFIX)/share/panucci
47 mkdir -p $(DESTDIR)/$(PREFIX)/share/applications/hildon
48 mv $(DESTDIR)/$(PREFIX)/share/applications/*.desktop $(DESTDIR)/$(PREFIX)/share/applications/hildon
50 binary-arch:
52 binary-indep: build install
53 dh_testdir
54 dh_testroot
55 dh_installchangelogs $(CHANGELOG)
56 dh_installdocs $(DOCS)
57 dh_installmenu
58 dh_installman
59 dh_compress
60 dh_fixperms
61 dh_installdeb
62 dh_gencontrol
63 dh_md5sums
64 dh_builddeb
66 binary: binary-indep
68 .PHONY: build clean binary-indep binary-arch binary install configure