Makefile.PL: declare explicit Time::HiRes dependency
[perl-MogileFS-Client.git] / debian / rules
blobf4fd140ace117fbe0aae9f92b9f45c0cdb797239
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
8 # This is the debhelper compatibility version to use.
9 # export DH_COMPAT=4
11 TMP =$(CURDIR)/debian/tmp
14 build: build-stamp
15 build-stamp:
16 dh_testdir
17 # Add here commands to compile the package.
18 perl Makefile.PL verbose INSTALLDIRS=vendor
19 $(MAKE)
20 touch build-stamp
22 clean:
23 dh_testdir
24 dh_testroot
26 -$(MAKE) clean
27 rm -f Makefile.old
28 dh_clean build-stamp install-stamp
30 install: build install-stamp
31 install-stamp:
32 dh_testdir
33 dh_testroot
34 dh_clean -k
35 dh_installdirs
37 $(MAKE) pure_install DESTDIR=$(TMP) PREFIX=/usr
39 touch install-stamp
41 binary-arch:;
42 binary-indep: build install
43 dh_testdir
44 dh_testroot
45 dh_installdocs
46 dh_installman
47 dh_installchangelogs
48 dh_install --sourcedir=$(TMP) --fail-missing
49 dh_link
50 dh_strip
51 dh_compress
52 dh_fixperms
53 dh_installdeb
54 dh_perl
55 dh_gencontrol
56 dh_md5sums
57 dh_builddeb
59 binary: binary-indep binary-arch
60 .PHONY: build clean binary-indep binary-arch binary install configure