Merge pull request #23 from dsteinbrunner/patch-2
[perlbal.git] / debian / rules
blob46e96c9344de7fabf1722505fbaf92e9810a58ac
1 #!/usr/bin/make -f
2 # This debian/rules file is provided as a template for normal perl
3 # packages. It was created by Marc Brockschmidt <marc@dch-faq.de> for
4 # the Debian Perl Group (http://pkg-perl.alioth.debian.org/) but may
5 # be used freely wherever it is useful.
7 # Uncomment this to turn on verbose mode.
8 #export DH_VERBOSE=1
10 # If set to a true value then MakeMaker's prompt function will
11 # always return the default without waiting for user input.
12 export PERL_MM_USE_DEFAULT=1
14 ifndef PERL
15 PERL = /usr/bin/perl
16 endif
18 TMP =$(CURDIR)/debian/tmp
20 build: build-stamp
21 build-stamp:
22 dh_testdir
24 # Add commands to compile the package here
25 $(PERL) Makefile.PL verbose INSTALLDIRS=vendor
26 $(MAKE)
28 touch build-stamp
30 clean:
31 dh_testdir
32 dh_testroot
34 # Add commands to clean up after the build process here
35 -$(MAKE) distclean
37 dh_clean build-stamp install-stamp
39 install: build install-stamp
40 install-stamp:
41 dh_testdir
42 dh_testroot
43 dh_clean -k
45 dh_installdirs -A
47 # $(MAKE) test
48 $(MAKE) pure_install DESTDIR=$(TMP) PREFIX=/usr
50 find $(TMP) -name .packlist -exec rm '{}' \;
51 find $(TMP) -depth -type d -empty -exec rmdir '{}' \;
53 dh_install --sourcedir=$(TMP)
55 touch install-stamp
57 binary-arch:
58 # We have nothing to do by default.
60 binary-indep: build install
61 dh_testdir
62 dh_testroot
63 # dh_installcron
64 # dh_installmenu
65 dh_installexamples
66 dh_installinit
67 dh_installdocs doc/hacking/todo.txt
68 dh_installchangelogs CHANGES
69 dh_perl
70 dh_link
71 dh_strip
72 dh_compress
73 dh_fixperms
74 dh_installdeb
75 dh_gencontrol
76 dh_md5sums
77 dh_builddeb
79 source diff:
80 @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
82 binary: binary-indep binary-arch
83 .PHONY: build clean binary-indep binary-arch binary