2 # This debian/rules file is provided as a template for normal perl
3 # packages. It was created by Marc Brockschmidt <marc@dch-faq.de> for
4 # the Debian Perl Group (http://pkg-perl.alioth.debian.org/) but may
5 # be used freely wherever it is useful.
7 # Uncomment this to turn on verbose mode.
10 # If set to a true value then MakeMaker's prompt function will
11 # always return the default without waiting for user input.
12 export PERL_MM_USE_DEFAULT
=1
18 TMP
=$(CURDIR
)/debian
/tmp
24 # Add commands to compile the package here
25 $(PERL
) Makefile.PL verbose INSTALLDIRS
=vendor
34 # Add commands to clean up after the build process here
37 dh_clean build-stamp install-stamp
39 install: build install-stamp
48 $(MAKE
) pure_install DESTDIR
=$(TMP
) PREFIX
=/usr
50 find
$(TMP
) -name .packlist
-exec
rm '{}' \
;
51 find
$(TMP
) -depth
-type d
-empty
-exec rmdir
'{}' \
;
53 dh_install
--sourcedir
=$(TMP
)
58 # We have nothing to do by default.
60 binary-indep
: build
install
67 dh_installdocs doc
/hacking
/todo.txt
68 dh_installchangelogs CHANGES
80 @echo
>&2 'source and diff are obsolete - use dpkg-source -b'; false
82 binary
: binary-indep binary-arch
83 .PHONY
: build
clean binary-indep binary-arch binary