1 # Test decoding only the commit record of the transaction that have
5 DROP TABLE IF EXISTS tbl1
;
6 DROP TABLE IF EXISTS tbl2
;
7 CREATE TABLE tbl1
(val1 integer
, val2 integer
);
8 CREATE TABLE tbl2
(val1 integer
, val2 integer
);
9 CREATE TABLE user_cat
(val1 integer
) WITH
(user_catalog_table
= true
);
17 SELECT 'stop' FROM pg_drop_replication_slot
('isolation_slot'
);
21 setup
{ SET synchronous_commit
=on
; }
22 step "s0_init"
{ SELECT 'init' FROM pg_create_logical_replication_slot
('isolation_slot'
, 'test_decoding'
); }
23 step "s0_begin"
{ BEGIN
; }
24 step "s0_savepoint"
{ SAVEPOINT sp1
; }
25 step "s0_truncate"
{ TRUNCATE tbl1
; }
26 step "s0_insert"
{ INSERT INTO tbl1 VALUES
(1); }
27 step "s0_insert2"
{ INSERT INTO user_cat VALUES
(1); }
28 step "s0_commit"
{ COMMIT
; }
31 setup
{ SET synchronous_commit
=on
; }
32 step "s1_checkpoint"
{ CHECKPOINT
; }
33 step "s1_get_changes"
{ SELECT data FROM pg_logical_slot_get_changes
('isolation_slot'
, NULL
, NULL
, 'skip
-empty
-xacts'
, '
1'
, 'include
-xids'
, '
0'
); }
36 setup
{ SET synchronous_commit
=on
; }
37 step "s2_begin"
{ BEGIN
; }
38 step "s2_truncate"
{ TRUNCATE tbl2
; }
39 step "s2_commit"
{ COMMIT
; }
41 # For the transaction that TRUNCATEd the table tbl1, the last decoding decodes
42 # only its COMMIT record, because it starts from the RUNNING_XACTS record emitted
43 # during the first checkpoint execution. This transaction must be marked as
44 # containing catalog changes while decoding the COMMIT record and the decoding
45 # of the INSERT record must read the pg_class with the correct historic snapshot.
47 # Note that in a case where bgwriter wrote the RUNNING_XACTS record between "s0_commit"
48 # and "s0_begin", this doesn't happen as the decoding starts from the RUNNING_XACTS
49 # record written by bgwriter. One might think we can either stop the bgwriter or
50 # increase LOG_SNAPSHOT_INTERVAL_MS but it's not practical via tests.
51 permutation "s0_init" "s0_begin" "s0_savepoint" "s0_truncate" "s1_checkpoint" "s1_get_changes" "s0_commit" "s0_begin" "s0_insert" "s1_checkpoint" "s1_get_changes" "s0_commit" "s1_get_changes"
53 # Test that we can purge the old catalog modifying transactions after restoring
54 # them from the serialized snapshot. The first checkpoint will serialize the list
55 # of two catalog modifying xacts. The purpose of the second checkpoint is to allow
56 # partial pruning of the list of catalog modifying xact. The third checkpoint
57 # followed by get_changes establishes a restart_point at the first checkpoint LSN.
58 # The last get_changes will start decoding from the first checkpoint which
59 # restores the list of catalog modifying xacts and then while decoding the second
60 # checkpoint record it prunes one of the xacts in that list and when decoding the
61 # next checkpoint, it will completely prune that list.
62 permutation "s0_init" "s0_begin" "s0_truncate" "s2_begin" "s2_truncate" "s1_checkpoint" "s1_get_changes" "s0_commit" "s0_begin" "s0_insert" "s1_checkpoint" "s1_get_changes" "s2_commit" "s1_checkpoint" "s1_get_changes" "s0_commit" "s1_get_changes"
64 # Test that we can handle the case where there is no association between top-level
65 # transaction and its subtransactions. The last decoding restarts from the first
66 # checkpoint, decodes NEW_CID generated by "s0_insert2", and marks the subtransaction
67 # as containing catalog changes while adding tuple cids to its top-level transaction.
68 # During that, both transaction entries are created in ReorderBuffer as top-level
69 # transactions and have the same LSN. We check if the assertion check for the order
70 # of transaction LSNs in AssertTXNLsnOrder() is skipped since we are still before the
71 # LSN at which we start replaying the contents of transactions. Besides, when decoding
72 # the commit record of the top-level transaction, we must force the top-level
73 # transaction to do timetravel since one of its subtransactions has been marked as
74 # containing catalog changes.
75 permutation "s0_init" "s0_begin" "s0_savepoint" "s0_insert" "s1_checkpoint" "s1_get_changes" "s0_insert2" "s0_commit" "s0_begin" "s0_insert" "s1_checkpoint" "s1_get_changes" "s0_commit" "s1_get_changes"