xulrunner, mozilla-firefox: Remove beta for now
[phenriksson.git] / local-gnome / x11-libs / goffice / goffice-0.7.15.ebuild
blob6901bcf30db4bf9e505244dd518ab45828ff01ed
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/x11-libs/goffice/goffice-0.6.5.ebuild,v 1.2 2008/09/28 07:59:23 aballier Exp $
5 EAPI=2
7 inherit eutils gnome2 flag-o-matic
9 DESCRIPTION="A library of document-centric objects and utilities"
10 HOMEPAGE="http://freshmeat.net/projects/goffice/"
12 LICENSE="GPL-2"
13 SLOT="0.8"
14 KEYWORDS="~x86"
15 IUSE="doc gconf gnome"
17 #FIXME Add optional dep on lasem (http://www.ohloh.net/p/Lasem)
19 RDEPEND=">=dev-libs/glib-2.16
20         gconf? ( gnome-base/gconf )
21         >=gnome-extra/libgsf-1.14.9[gnome]
22         >=dev-libs/libxml2-2.4.12
23         >=x11-libs/pango-1.8.1
24         >=x11-libs/gtk+-2.12
25         >=x11-libs/cairo-1.2[svg]"
27 DEPEND="${RDEPEND}
28         >=dev-util/pkgconfig-0.18
29         >=dev-util/intltool-0.35
30         doc? ( >=dev-util/gtk-doc-1.4 )"
32 DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README"
34 pkg_setup() {
35         G2CONF="${G2CONF}
36                 $(use_with gnome)
37                 $(use_with gconf)"
40 src_compile() {
41         filter-flags -ffast-math
42         gnome2_src_compile